Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Zenmuse H3-3D no FPV

Discussion in 'Phantom 2 Help' started by Matto, Jun 11, 2015.

  1. Matto

    Joined:
    Jul 18, 2014
    Messages:
    6
    Likes Received:
    0
    Hello all,


    I've recently run into the problem of the broken usb connector on my H3-3D. This had happened before and I used the backup that came with the gimbal but it's now broken again to no surprise at all. So I've now replaced it a 3rd time but now the gimbal will not function if the connector is plugged into the usb port on the gopro. If I leave it unplugged it seems to function normally but if plugged in the gimbal is bricked. Has anyone else encountered this?


    Cheers
     
  2. Matto

    Joined:
    Jul 18, 2014
    Messages:
    6
    Likes Received:
    0
    I should add that I've tried with multiple connectors so it's not a bad one of those.
     
  3. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,099
    Likes Received:
    404
    Location:
    Commerce Twp,MI
    Were those ribbon cables original DJI parts or after market?
     
  4. Matto

    Joined:
    Jul 18, 2014
    Messages:
    6
    Likes Received:
    0
    They're genuine DJI parts as far as I can tell by the packaging
     
  5. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,410
    Likes Received:
    567
    Location:
    Sydney Australia
    I think you installed the ribbon cable backwards/upside down. The long thin end sits outside and plugs into the gopro. The short chubby end goes into the plate.