Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Yellow flashing lights

Discussion in 'Phantom 1 Help' started by Marc70, Jan 28, 2015.

  1. Marc70

    Joined:
    Dec 26, 2013
    Messages:
    87
    Likes Received:
    0
    I have the P 1.1.1, crashed, and repaired from dealer. He said alls good, but I just had yellow flashing light. Tried lots, then took it apart to find gps not connected, so that should be it. No dice. Still fast flashing yellow. Software shows gps and compass seem connected (changing values when software connected).
    Anything else I can do? Don't want to pay shipping again for something I could do.
    Thanks to all that can help.
     
  2. CityZen

    Joined:
    Oct 22, 2014
    Messages:
    940
    Likes Received:
    36
    Location:
    NYC
    Fast yellow? Bind the remote.
     
  3. Buckaye

    Joined:
    Aug 24, 2014
    Messages:
    1,557
    Likes Received:
    420
    Location:
    Orlando
    This is a reposted thread :( I made the same suggestion in the other thread and he said he tried that.

    at this point - i'd say send it back - because the error indication on the LED is a TX binding issue.
     
  4. Marc70

    Joined:
    Dec 26, 2013
    Messages:
    87
    Likes Received:
    0
    Thanks for the replies, guys.
    I'm at my wits end. The compass and gps show activity on the software.
    When the dealer sent it back to me, we were to split the $240 cost of repairs. I asked how he wanted me to pay, but he never replied back. Just sent the unit,but said he couldn't be sure it binded, as he didn't have the tx.
    I don't want to send it again, was hoping there's another solution I'm not aware of?
    Tried rebinding several times, but does the blinking light have to stay blinking while rebinding?
    Again, thanks to all.
    Reposted here hoping for more help.
     
  5. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,101
    Likes Received:
    404
    Location:
    Commerce Twp,MI
    Have you calibrated both the RC all sticks and Xi and done the same with the phantom? If not do both then calibrate the compass.
     
  6. CityZen

    Joined:
    Oct 22, 2014
    Messages:
    940
    Likes Received:
    36
    Location:
    NYC
    Okay, so there are several things to check:
    1) Make sure you're doing the rebinding right. You hold down the receiver bind button until the receiver LED changes its pattern. Release it, then turn on the transmitter. The receiver LED should go out.
    2) Make sure the proper receiver type is selected in the Naza Assistant software. Should be Dbus, not PPM.
    3) Make sure the wires from the receiver are plugged into the Naza correctly. The cable closer to the battery door goes to X2; the other to X1.