Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

yellow flashing - 2 times

Discussion in 'General Discussion' started by berndgill, Aug 10, 2013.

  1. berndgill

    Aug 10, 2013
    Likes Received:

    I have some problems with my phantom. The compass always had issues and the Mod Value was always around 650.
    I upgraded the firmware to 3.16 and when I went outside I got after warmup the 2 yellow flashes (and they do not go away).
    So I ordered a new compass one and replaced the old one.

    Again the 2 yellow flashes.
    Then I downgraded to 3.14 and did n Advanced and a Basic calibration.

    Suddenly I could calibrate the compass and everything worked.
    Now when downgrading it went from an X to a + model - so it did not fly.

    I changed it and recalibrated it.

    Inside it it showed me everything OK (even without calibration) but could not find the satellite

    When I turned it off, went outside and turned it on again I only got again the 2 yellow flashes.

    I have not found any information on these 2 yellow flashes.
    And the compass values are still 000 0

    Does anyone know what is the problem?



  2. natscape

    Jun 18, 2013
    Likes Received:
    Do you get the 3 RED flashes after the 2 yellow flashes?

    Also, could you post a screenshot of the Tools section in Naza Assistant?
  3. martcerv

    May 27, 2013
    Likes Received:
    2 Yellow flashes on their own show its in ATTI mode and sticks not centered, if you center both sticks this should then be just a single yellow flash. Any red flashes after this show how many satellites have been found.


    The most likely reason for this is your GPS is not functioning and so it wont go into GPS mode which would be 2 or 1 green light depending on stick positions. Possibly a crash may have cracked the GPS antenna as there have been a few people who have had this happen or its simply not connected properly. Also a large compass error caused by a strong magnet near the compass at some point, possibly you screwed it on with a strong magnetic screwdriver when replacing it? Compass errors will show up as red and yellow led so this is not your likely issue.