Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Yawing

Discussion in 'Phantom 1 Help' started by Mr.P, Apr 18, 2014.

  1. Mr.P

    Joined:
    Apr 18, 2014
    Messages:
    18
    Likes Received:
    0
    Hi Folks & Thanks in advance for any help received .

    Since updating the phantom firmware to 3.0, I've not been able to spin on the spot as well as I did with the original firmware. When yawing, rather than turning around on the spot in a circular fashion, it spins whilst drifting into another direction without instructing the phantom to do so.

    I've tried recalibrating the cumpus via the app on the desktop as well as a basic reset.

    I was wondering if there was a way of restoring the original firmware - or if there's another way to fix this issue?

    Any thoughts on this gratefully received.
     
  2. Madwak

    Joined:
    Apr 2, 2014
    Messages:
    291
    Likes Received:
    1
    You can downgrade from 3 back to 2 if you get this from the dji website if you havnt got it already Phantom 2 Vision Assistant Software v2.00 2014-03-26. If you use this instead of the v3.00 assistant it will say upgrade available but when you upgrade it actually downgrades to v2.00.
     
  3. Mr.P

    Joined:
    Apr 18, 2014
    Messages:
    18
    Likes Received:
    0
    Ok thanks for this info.

    It's also been suggested elsewhere that the Naza might not be connected inside correctly so the GPS is not defining the spot correctly to orientate around on.

    Currently being defeated by the tiny screws at the end underneath the rotors! grr.

    Will let you know the answer once fixed...
     
  4. Mr.P

    Joined:
    Apr 18, 2014
    Messages:
    18
    Likes Received:
    0
    Ok so I've down graded the firmware to v2 & recalibrated with no difference with the flying behaviour.

    The symptoms are:

    1) when yawing the copter spins around in a vague circular shape rather than on the spot
    2) when overing the craft is at an angel - rather than being completely flat adjustments on the RC is needed to keep it stable.
    3) sometimes hovers radically up and down - needs input from RC to stabilise.

    Is there a "factory reset" anywhere / any other suggestions - anybody had any similar symptoms?

    Any thoughts folks?

    Many thanks.
     
  5. EMCSQUAR

    Joined:
    Sep 5, 2013
    Messages:
    1,692
    Likes Received:
    6
    Location:
    N 44.895 W 93.354 Minnesota
    Recalibrate everything after doing software change. Do an advance IMU calibration, stick calibration and before flight a compass calibration... call me in the morning
     
  6. Madwak

    Joined:
    Apr 2, 2014
    Messages:
    291
    Likes Received:
    1
    An advanced IMU calibration should sort this out but you have make SURE the surface that you do it on is absolutely level as this is what makes the phantom level when hovering, and don't forget the compass calibration afterwards as already suggested.
     
  7. Mr.P

    Joined:
    Apr 18, 2014
    Messages:
    18
    Likes Received:
    0
    Ok so now the motors are failing to start due to this error message. When calibrating it's not central on the stick calibration window either - although it is.

    Any thoughts?

    Thanks.

    A.

    Motors Start failure caused by TX stick(s) mid point error too big
    If the TX stick(s) mid point error is too big, Motors Start will fail when you execute the Combination Stick Commands (CSC) and lead to the aircraft will not takeoff.. And the LED will blink Red four times per second continually to warn you.
    TX stick(s) mid point error too big can be caused by the following reasons:
    (1) There is TX stick (except the throttle stick) not at center when power on the autopilot system.
    (2) The TX sticks has been trimmed, which leads to the large deviation of mid point. For example, the SUB-TRIM has been adjusted for Futaba transmitter.
    (3) The TX stick(s) travel has larger asymmetry.
    For the reason (1), please put all TX sticks at the mid point, and then power cycle the autopilot system to re-record the mid point. If the problem continues, that can be caused by the reason (2) or reason (3), you need to adjust the output range of your TX, and then use the Assistant Software to redo the TX calibration. Please carry out the following procedures.
    (1) Connect to the Assistant software, click Basic-> R/C-> Command Sticks Calibration, and push all TX sticks throughout their complete travel range to see if any stick cannot reach its largest position.
    (2) Adjust the largest travel of TX stick until the cursor on the Assistant software can reach both end positions, according to your TX manual.
    (3) Power cycle the autopilot system, note that power cycle is required.
    (4) Redo the TX calibration according to the Assistant software.
     
  8. Madwak

    Joined:
    Apr 2, 2014
    Messages:
    291
    Likes Received:
    1
    My thoughts are do what it suggests in 1 to 4 and see what happens.
     
  9. rjf

    rjf

    Joined:
    Apr 14, 2014
    Messages:
    11
    Likes Received:
    0
    Prop Problems

    I had a crash but got the phantom up and flying again right after this crash, it flew fine, that was about two weeks ago. So today I went out to fly and one of the props would turn but only erraticly any ideas?
     
  10. Mr.P

    Joined:
    Apr 18, 2014
    Messages:
    18
    Likes Received:
    0
    Interesting, I did a full calibration last night and flew this morning the phantom also flipped/crashed. Still seems to be 'drifting' though. Appears to be more agile or a sensitivity increase, although it did seem more stable when hovering for a few seconds.

    My motors are spinning fine.... :shock:
     
  11. Mr.P

    Joined:
    Apr 18, 2014
    Messages:
    18
    Likes Received:
    0
  12. EMCSQUAR

    Joined:
    Sep 5, 2013
    Messages:
    1,692
    Likes Received:
    6
    Location:
    N 44.895 W 93.354 Minnesota
    After seeing video, double check your settings on Futaba.. sub trims and your left stick travel #s
     
  13. Mr.P

    Joined:
    Apr 18, 2014
    Messages:
    18
    Likes Received:
    0
    Thanks for this. However as there isn't an obvious link within the website, a direct link would be most appreciated :D
     
  14. Mr.P

    Joined:
    Apr 18, 2014
    Messages:
    18
    Likes Received:
    0
    Solved.

    There were 4 things I did which helped in addition:

    1) I took the foam off the legs to make it even.
    2) placed the craft on the floor and not the desk because the floor is more even.
    3) Allowed the phantom to 'cool' down for 5 mins before calibration

    4) When doing the compass calibration the 3rd /4th time was a lot better - more stable etc and continued to be so. However, on the first time the symptoms were still evident

    Thanks for your help all :D