Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

X1 dead after firmware 4.0. HELP??

Discussion in 'Firmware' started by Mikkiii, Sep 24, 2013.

  1. Mikkiii

    Joined:
    Sep 23, 2013
    Messages:
    4
    Likes Received:
    0
    Hi all, Just this weekend installed my new Zenmuse H3 and the upgrade board, updated firmware to 4.0 and calibrated everything. Now my RC won't go in PPM mode, but D-Bus and everything seems to work except for the X1 lever to tilt the GoPro. Cannot calibrate it, slider just won't move. So now my GoPro is facing down, is steady, but only drop-shots... don't think so :(
    Anyone similar experience/suggestions or help????
     
  2. jumanoc

    Joined:
    Jan 21, 2013
    Messages:
    700
    Likes Received:
    8
    Did you load Default Phantom Parameters ? Check if the GIMBAL page is correct with X1. Also calibrate X1 stick with Naza Assistant.

    [​IMG]
     
  3. Mikkiii

    Joined:
    Sep 23, 2013
    Messages:
    4
    Likes Received:
    0
    Yes I did and GIMBAL page is correct with X1. Tried to calibrate using the assistant and meanwhile turning the screw in the RC, but nothing moves in the calibrating area...
     
Loading...
Similar Threads - dead firmware HELP Forum Date
Dead Gimbal after firmware update. Phantom 4 Pro Discussion Dec 15, 2016
Professional Camera Gimbal Dead after Firmware Update Phantom 3 Help Feb 13, 2016
Advanced Done the dreaded firmware update, bird now dead Phantom 3 Help Sep 19, 2015
Gimbal dead after latest firmware update Firmware Oct 31, 2014
Phantom RC dead during firmware upgrade Firmware Sep 29, 2014