Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Wondering p2v+3.0

Discussion in 'Phantom 2 Vision + Help' started by Alan Miller, Jul 19, 2015.

  1. Alan Miller

    Joined:
    Apr 20, 2015
    Messages:
    18
    Likes Received:
    1
    I Got a new phantom 2 vision plus 3.0. Did all updates and calibrations. The unit seems to wonder about 10 ft when in GPS mode when trying to rotate on an axis. It drifts about 10 to 12 ft off center.
    ANY IDEAS?
     
  2. dirkclod

    dirkclod Moderator
    Staff Member

    Joined:
    May 9, 2014
    Messages:
    10,625
    Likes Received:
    5,693
    Location:
    Amory Mississippi
    Sounds like you need to do a Advanced IMU Calibration Alan .
    JMT
     
  3. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,782
    Likes Received:
    5,525
    Location:
    US
    #3 msinger, Jul 19, 2015
    Last edited: Oct 27, 2015
  4. dirkclod

    dirkclod Moderator
    Staff Member

    Joined:
    May 9, 2014
    Messages:
    10,625
    Likes Received:
    5,693
    Location:
    Amory Mississippi
  5. sdtag

    Joined:
    Apr 5, 2015
    Messages:
    221
    Likes Received:
    23
    that is a lot of reading but you should do it.
    The bottom line is to get your quad dead nuts level before you do the advanced calibration.
    I mean be **** about it. the more perfectly level it is the better it will fly (spin).
     
    dirkclod likes this.
  6. gandolph27

    Joined:
    Jul 26, 2015
    Messages:
    2
    Likes Received:
    1
    I had a really bad yaw drift and it was due to the gps plug fitting loose! I pushed it down securely and did an advance calibration using glass on top of the motors and a bubble level and after that it flew just like it did out of the box the connection was being broken during flight and I was losing sats that's why I was getting the drift! This fixed mine hopefully it'll help someone else.
     
    dirkclod likes this.
  7. dirkclod

    dirkclod Moderator
    Staff Member

    Joined:
    May 9, 2014
    Messages:
    10,625
    Likes Received:
    5,693
    Location:
    Amory Mississippi
    I put a little hot glue where that connection is to help hold it in. Seems to do pretty good !
    Glad you got yours worked out gand !
    Welcome to the forum :)