Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Will v1.4 install v1.3 on the batteries?

Discussion in 'Pro/Adv Discussion' started by 0100, Sep 8, 2015.

  1. 0100

    Joined:
    Jul 3, 2015
    Messages:
    29
    Likes Received:
    0
    Ok I have a p3p and 4 batteries with old 1.2 firmware.

    I know with the remote I will have to install the 1.3 firmware.

    The question I have is with the 1.4 firmware on the card (and in the quad) will it install the 1.3 firmware on the batteries?
     
  2. brianb87

    Joined:
    Aug 21, 2015
    Messages:
    788
    Likes Received:
    148
    I think if you leave the firmware on the SD card. Don't quote me on that though. Just what I have read on this forum. Try a search to confirm or contact a DJI Rep. Good luck !
     
    #2 brianb87, Sep 8, 2015
    Last edited: Sep 8, 2015
  3. 0100

    Joined:
    Jul 3, 2015
    Messages:
    29
    Likes Received:
    0
    Yeah I can't find anywhere that says if it will install 1.3 on the batteries or not.

    Just not sure if I should do 1.3 for everything(p3 and batteries) then go back and do 1.4 on the p3...
     
  4. StevenQX

    Joined:
    Mar 1, 2015
    Messages:
    786
    Likes Received:
    185
    Location:
    Italy
    Good question. I was wondering the same. How to update batteries leaving the aircraft with latest firmware?
     
  5. 0100

    Joined:
    Jul 3, 2015
    Messages:
    29
    Likes Received:
    0
    How can you check the batteries firmware?
     
  6. D4T_PoM

    Joined:
    Jul 28, 2015
    Messages:
    693
    Likes Received:
    183
    Location:
    London UK
    I was thinking the same, I'm on 1.1.9
     
  7. 0100

    Joined:
    Jul 3, 2015
    Messages:
    29
    Likes Received:
    0
    So no one knows...
     
  8. TJ_514

    Joined:
    Jul 7, 2015
    Messages:
    11
    Likes Received:
    0
    you have to put 1.3.20 on your sd card first mate. update your TX and batteries with 1.3.20 and then update the bird using 1.4

    i just did it.
     
  9. TJ_514

    Joined:
    Jul 7, 2015
    Messages:
    11
    Likes Received:
    0
    just to clarify. i went from a never updated bird to 1.4 ..... just like what your dealing with.
     
  10. 0100

    Joined:
    Jul 3, 2015
    Messages:
    29
    Likes Received:
    0

    Ok but now let's say you buy a spare battery next week with who knows how old firmware on it. How do you upgrade the firmware on the battery to 1.3 when the bird would now be on 1.4?
     
  11. StevenQX

    Joined:
    Mar 1, 2015
    Messages:
    786
    Likes Received:
    185
    Location:
    Italy
    I believe in what wrotes @Mako79 in the other thread. If you check the log from update you will see that before to update the aircraft check which part of the firmware needs to be updated and updates only the ones who needs to be updated. I don't think is enough to put an older firmware in the sd to downgrade the bird. Few weeks ago here on this forum there was a thread where was explained how to downgrade the firmware. But afair it was not so simple to just put an older version in the sd card and switch on the aircraft.