Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Will not start

Discussion in 'Phantom 2 Vision Discussion' started by isle, Feb 11, 2015.

  1. isle

    Joined:
    Apr 13, 2014
    Messages:
    155
    Likes Received:
    3
    Can't get quad to fire up so I go to trouble shoot in manual and do step one, is power cycle just pull battery out and put back in? Do I do this with battery on or off, anyway when that did not work I tried step two and controller will not connect with RC firmware and will connect with vision firmware. Also manual says it should be set to FCC not CS well mine was set to CS and finally when you power on quad you get a humming noise that sputters gets louder and softer and sometimes it is silent does not sound right to me. I am starting to think this had been returned once and now I got it. Got through Amazon so they should take it back. Any thoughts
     
  2. usaken

    Joined:
    Mar 30, 2014
    Messages:
    113
    Likes Received:
    0
    Location:
    Northern California USA
    The sputtering sound is probably the gimbel, the fan inside sputters. As for the no start, I had the same problem. it probably has to do with the stick settings on the remote. One of the more experienced pilots helped me fix mine after having the same problem.
     
  3. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,906
    Likes Received:
    5,567
    Location:
    US
    To power cycle the battery, just turn it off and back on via the button. You do not have to remove the battery from your Phantom.

    Make sure the USB cable is plugged into your remote controller when using the R/C Assistant.

    My gimbal usually makes a humming/vibrating sound for 10 seconds or so when I turn on my Phantom. If that's where the sound is coming from, then it's nothing to worry about.
     
  4. isle

    Joined:
    Apr 13, 2014
    Messages:
    155
    Likes Received:
    3
    I must be blind where is usb connection on controller
     
  5. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,906
    Likes Received:
    5,567
    Location:
    US
    It's on the bottom of the controller.
     
  6. CityZen

    Joined:
    Oct 22, 2014
    Messages:
    940
    Likes Received:
    36
    Location:
    NYC
    Some controllers do not have an external USB port. For these, the USB port is inside.

    But leave that as secondary for now. Plug the Phantom into the computer, run the Phantom Assistant, and go to the RC screen. Calibrate the remote, and make sure the NORM/REV buttons all say NORM.
     
  7. isle

    Joined:
    Apr 13, 2014
    Messages:
    155
    Likes Received:
    3
    That's the problem I can not calibrate remote because I can not access the firmware . My remote does not have port on bottom this is starting to get frustrating. My fc40 was no problem to set up and fly, is this not the same just with better camera?
     
  8. AmosMoses

    Joined:
    Mar 22, 2014
    Messages:
    597
    Likes Received:
    161
    Location:
    Illinois
    If you don't have a USB port on the outside of the tx you have to open it up. It's on the inside of the older controllers.
     
  9. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    Try this first, you may not need to plug into the TX, there are two stages to doing it.
    - try doing only the second stage while connected to phantom via assistant software.
    If it's not seeing the phantom it's usually because you need to download the driver manually from DJI site.