Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Wifi - Wont connect to Galaxy III

Discussion in 'Phantom 2 Vision Help' started by duckdogs007, Feb 26, 2014.

  1. duckdogs007

    Joined:
    Jan 23, 2014
    Messages:
    50
    Likes Received:
    7
    I get "No Internet Connection"...when recently trying to connect to my Vision 2 wifi....this just started in the last week or so, used to work fine.

    I have good Wifi signal - all green on camera.

    any ideas?

    thanks!
    :?:
     
  2. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
    Have you tried WiFi Settings > Advanced > Auto Network Switch and uncheck the box?

    This should prevent it dumping your Phantom network and looking for one with an internet connection (one of your apps is probably looking for the big wide world and if network switch is enabled the phone will go and look for a "better" network.
     
  3. duckdogs007

    Joined:
    Jan 23, 2014
    Messages:
    50
    Likes Received:
    7
    My device does not have a "auto network switch" option...

    But it detects the Phantom wifi and shows a good signal strength to it on the meter, however when I attempt to "connect" to it, it states "No internet connection"...so I am not able to connect to it.
     
  4. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
    Hopefully someone with the same device and flavour of android can advise soon, then.
     
  5. jadebox

    Joined:
    Nov 20, 2013
    Messages:
    490
    Likes Received:
    51
    Location:
    Oviedo, FL
    You're not going to have an internet connection when connected to the Phantom's WiFi. If you're just getting a warning message that says that, but it still stays connected then you're probably okay.

    If it disconnects because of the lack of an internet connection then there's probably a setting similar to the "Auto Network Switch" that pull_up mentioned that needs to be changed. if there's an "Advanced" option under WiFi/Settings, see what's there and try changing some things to see if it helps.

    -- Roger
     
  6. duckdogs007

    Joined:
    Jan 23, 2014
    Messages:
    50
    Likes Received:
    7
    It won't connect to the Phantom WiFi....and it has previously...

    when I try, it gives that error, saying No Internet Connection...

    Advanced settings only have Proxy and IP settings.
     
  7. duckdogs007

    Joined:
    Jan 23, 2014
    Messages:
    50
    Likes Received:
    7
    It appears that when you activate the "airplane mode" then the Wi-Fi to the Phantom, takes care of this problem...

    Not sure why this started happening here lately, but this fix worked!
     
  8. nintendrone64

    Joined:
    Feb 19, 2014
    Messages:
    353
    Likes Received:
    2
    Location:
    Simi Valley, CA
    What?
    When you ACTIVATE airplane mode it works?!
    That's crazy! I thought when you enable Airplane mode it's supposed to disable all data/wireless data coming from the phone...
     
  9. JonC

    Joined:
    Apr 4, 2016
    Messages:
    1
    Likes Received:
    0
    WOW THIS ACTUALLY WORKED!!!! I have a Phantom 3 Standard with a Galaxy S4. The wifi connection wouldn't stay on for more than a minute at a time. I scoured the internet and tried all of the advanced settings, turned off bluetooth, forgot my home wifi network, uninstalled Google Play auto-updates, disabled auto-updating, downloaded a wifi analyzer, etc etc, nothing worked. Tried Airplane Mode, turned on wifi - solid, stable signal!! Hallelujah! Thanks DuckDogs!
     
  10. crash1sttime

    Joined:
    Oct 31, 2014
    Messages:
    928
    Likes Received:
    74
    Location:
    Manchester UK
    Activate airplane mode, this does disable wifi, but then just enable wifi, early android devices had the auto network switch setting which you could turn off however some newer versions removed this so Airplane mode with wifi activated is the only option.


    Sent from my iPhone using PhantomPilots mobile app