Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Which version of iPod Touch

Discussion in 'Phantom 2 Vision + Discussion' started by Rickesco, May 20, 2014.

  1. Rickesco

    Joined:
    May 20, 2014
    Messages:
    55
    Likes Received:
    0
    Location:
    Palmdale, California
    First of all, I'm new with the Phantom. I moved up from the Blade 350QX. I Purchased the Phantom Vision 2 plus, I do have a question. I really dont want to use my iPhone, so what generation of iPod Touch will work. I have an early version ( prob Gen 1 or 2) and It will not work. Any help would be appreciated.

    Thank you
    Rick
     
  2. MikesTooLz

    Joined:
    Apr 15, 2014
    Messages:
    326
    Likes Received:
    0
    Location:
    Miami, Florida
    go to the app store and look at the Vision app.

    It will say that it works on iOS versions xxx and up. You need an ipod touch running at least what ever version of iOS the app requires or higher. Keep in mind that as new versions of iOS come out, developers tend to not support much older versions of iOS and expect users to upgrade iOS as newer versions come out. If you get an iOS device I would say that you are safe keeping it running the latest verison of iOS for about 4 years before apple stops supporting the device.