Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

When it rains?

Discussion in 'Phantom 2 Vision + Discussion' started by andrew, Aug 1, 2014.

  1. andrew

    Joined:
    Jun 26, 2014
    Messages:
    73
    Likes Received:
    1
    Ok. I'd rather come here and share exciting stories or some great video, but it seems for me that when it rains, it pours... I updated the copter to the lastest version, no proble. I attempted to update the transmitter to the latest firmware, half way through the update my TX lost power. I cycled the power, no luck. I checked the batteries, all good. I opened it up, joints look good, main board is getting power (used a multimeter). No mods to this TX and it's only a couple months old.

    I'm at a loss... Coincidence during the firmware update or what? Sigh...
     
  2. srandall25

    Joined:
    Apr 17, 2014
    Messages:
    692
    Likes Received:
    4
    Is your Tx modded? Did you have an antenna connected to it when you applied power? I read somewhere that if you power your Tx without an antenna connected, it could burn up the board... just an idea...
     
  3. andrew

    Joined:
    Jun 26, 2014
    Messages:
    73
    Likes Received:
    1
    Nope, no mods and the antenna was connected..
     
  4. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    9
    Location:
    Glen Burnie, MD - USA
    Remove the back of the controller. There is a small reset button on the circuit board. Hold the button while powering on the transmitter.
     
  5. Mori55

    Joined:
    Feb 13, 2014
    Messages:
    1,993
    Likes Received:
    6
    Location:
    NJ-USA
    I didn't think their was a transmitter upgrade ?
     
  6. andrew

    Joined:
    Jun 26, 2014
    Messages:
    73
    Likes Received:
    1
    Fixed. Appears it failed half way through the upgrade and went into loader mode. I was able to reapply the update and now it works fine. Thanks.