Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

When 2.7k arrived on advanced?

Discussion in 'Pro/Adv Discussion' started by Καλλιστώ, Jan 15, 2016.

  1. Καλλιστώ

    Joined:
    Dec 27, 2015
    Messages:
    77
    Likes Received:
    24
    Location:
    Italy
    Hello! My brand new advanced is just arrived, and I would like to keep it without all this geofencing madness, at least until dji adjust all the glitches...
    I'm using Android with dji go 2.0.2 and firmware 1.4.10+, but it seems possible to film @ 1080 max.
    So when the 2.7k feature came? On which app or firmware version?
    Thanks!
    P.S.:As far as I could see I've no yellow zone at all, just the red ones above airports etc...
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,117
    Likes Received:
    5,632
    Location:
    US
    It was added in firmware version 1.4.
     
  3. Καλλιστώ

    Joined:
    Dec 27, 2015
    Messages:
    77
    Likes Received:
    24
    Location:
    Italy
    Wow! That's a fast answer! If it so, I should see the option, or my firmware is not 1.4?
     
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,117
    Likes Received:
    5,632
    Location:
    US
    You definitely have 1.4 installed. You need to be running DJI GO 2.1 or higher though.
     
    Καλλιστώ likes this.
  5. Καλλιστώ

    Joined:
    Dec 27, 2015
    Messages:
    77
    Likes Received:
    24
    Location:
    Italy
    Thanks, I'll upgrade the app
     
  6. Καλλιστώ

    Joined:
    Dec 27, 2015
    Messages:
    77
    Likes Received:
    24
    Location:
    Italy
    I've tried, without great expectations, the dji chat. Spoken with two geniuses, they kept telling that the latest firmware is 1.6, to keep firmware and app updated....
     
  7. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,117
    Likes Received:
    5,632
    Location:
    US
    I don't know of any related fixes in 1.5 or 1.6, but using the latest firmware is not a bad suggestion. If you run into issues like this, DJI is obviously going to recommend trying the latest firmware. It's the easiest thing to try since it's the most bug-free version in their eyes. However, if you upgrade to 1.6, you cannot go back to 1.4 (if that's a concern of yours).
     
  8. Καλλιστώ

    Joined:
    Dec 27, 2015
    Messages:
    77
    Likes Received:
    24
    Location:
    Italy
    I'm really new to this game..
    I would like to avoid this geofencing stuff, at least to postpone it..
    Here in Italy their nfz and maps are really not consistent with the real nfz, to abide to local laws.
    I'll slowly update the app, and i'll stop when all my needs are satisfied (actually i need just 2.7k..)
    If that will not be enough i'll update the firmware too.

    P.S.: Generally speaking, i don't like to buy an item with specific features (like 2.7k video) and don't find in the package, or otherwise indicated, clear instructions on how to achieve what should be included, because is what they advertise...
     
  9. Kcam

    Joined:
    Dec 11, 2015
    Messages:
    23
    Likes Received:
    3
    I think the idea of clear instructions from a company in China is a pipe dream. For a unit that is $1000 I expect much better customer service but all dji cares about is the margins. They sell tons of these so they really don't care how they work when you get it. China just pushes the pieces of sh#@ they built to service centres in the US for repair knowing we have no choice.

    I'm sick of dji bullsh#@. I think I am selling and may scratch build something that actually works.
     
  10. Καλλιστώ

    Joined:
    Dec 27, 2015
    Messages:
    77
    Likes Received:
    24
    Location:
    Italy
    Ahahah, you're probably right.
     
  11. Καλλιστώ

    Joined:
    Dec 27, 2015
    Messages:
    77
    Likes Received:
    24
    Location:
    Italy
    Yes sir, you were right.
    Tried 2.1 and here it is 2.7k video.

    P.S.:RC 1.4.30+ , reasons to/not to update?
     
  12. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    9
    Location:
    Glen Burnie, MD - USA
    If you are happy with the way she flies then I suggest you leave things right where they are. If you go to 1.5 you get the battery shutdown issue & 1.6 you get the Geofencing. The problem is you can't go back to 1.4 if you go to 1.6...at least not easily.

    You should also disable Auto-updating of the app on your device.

     
  13. John Locke

    Joined:
    Jun 26, 2015
    Messages:
    2,994
    Likes Received:
    1,126
    Location:
    Yorba Linda, CA
    Don't ever fly 1.5, it's the kiss of death. Don't do it. 1.4 or 1.6, those are safe to fly.


    Sent from my iPad using PhantomPilots mobile app
     
  14. marzipana

    Joined:
    Jan 9, 2016
    Messages:
    290
    Likes Received:
    33
    There seem to be too many GPS dropout issues with 1.6...


    Sent from my iPhone using PhantomPilots mobile app
     
  15. RedHotPoker

    Joined:
    May 3, 2015
    Messages:
    3,972
    Likes Received:
    1,365
    Location:
    Edmonton Alberta
    Perhaps for some, but not for everyone of us. I have had wonderful flights and enjoyed all of the updates. So far never had a glitche problematic flight or any of the disasterous results that numerous others have lamented about.

    Sorry that all Phantom 3 pilots haven't experienced what these birds were meant to accomplish, and supply. It's been absolutely great here. Couldn't be any happier with my initial investment towards all this fun. ;-)
    Only ever lost my video connection a few times, but other than that, has been ultra-smooth sailing. I always hope, gee maybe this next firmware update will alleviate everyone's problemed Phantom, and they will finally experience these same utmost thrills, from their drone too. As of today, sadly that update hasn't arrived yet. Maybe soon?

    RedHotPoker
     
  16. John Locke

    Joined:
    Jun 26, 2015
    Messages:
    2,994
    Likes Received:
    1,126
    Location:
    Yorba Linda, CA
    1.5
    1.5 firmware reads the battery voltage wrong, lower than reality. At 3.0v on any cell the battery protection routine is triggered, sometimes shutting off all power. That's why birds have been falling from the sky, only on 1.5. That's why 1.5 was only out for a week or two when they replaced with 1.6. If you're flying 1.5, think of me when it falls from the sky. It's not like you weren't warned. This info came from DJI guys who were willing to talk about it at CES last weekend.
     
    #16 John Locke, Jan 16, 2016
    Last edited: Jan 16, 2016
  17. RedHotPoker

    Joined:
    May 3, 2015
    Messages:
    3,972
    Likes Received:
    1,365
    Location:
    Edmonton Alberta
    I have updated the morning of, with every update that has been released and never had a hiccup. ;-)

    I am not afraid to fly my trouble free drone with any new firmware or Go app.

    RedHotPoker
     
  18. DaGunn

    Joined:
    Jun 22, 2015
    Messages:
    163
    Likes Received:
    50
    John, are you referring to the public 1.5.30 or the SDK 1.5.11 on the phantom. Too many different version numbers to keep track of as to whats on your tablet, rc, bird, batteries. Thank you in advance for any clarification.

    Dave
     
  19. John Locke

    Joined:
    Jun 26, 2015
    Messages:
    2,994
    Likes Received:
    1,126
    Location:
    Yorba Linda, CA
    The public 1.5.3
     
    DaGunn likes this.
  20. John Locke

    Joined:
    Jun 26, 2015
    Messages:
    2,994
    Likes Received:
    1,126
    Location:
    Yorba Linda, CA
    It's possible to not have a problem if you start with a just charged battery and you don't go full throttle when the battery is less than 40%. If you're conservative it works, however there's a huge risk because nobody knows exactly where the limits as when battery protection kicks in, turning off all power, mid flight. Good luck if you ever fly 1.5.
     
    #20 John Locke, Jan 16, 2016
    Last edited: Jan 16, 2016