Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

what's wrong with my p2v+ ???

Discussion in 'Phantom 2 Vision + Discussion' started by Eason, Nov 29, 2014.

  1. Eason

    Joined:
    Nov 13, 2014
    Messages:
    4
    Likes Received:
    0
    [youtube]https://www.youtube.com/watch?v=4SkRTkcVXBk[/youtube]
    [youtube]https://www.youtube.com/watch?v=R_5esqU3is0[/youtube]

    when my p2v+ power on , the right-rear LEDs didn't light up at first , and show beep beep beep beep
    also the right-rear motor is slower obviously , but when flight time , everything seens all right , no strange situation
    anyone know how this is going and how to solve it?
    thanks !!!
     
  2. job2310

    Joined:
    Sep 1, 2014
    Messages:
    264
    Likes Received:
    0
    Location:
    Bristol, England
  3. aartsf

    Joined:
    Sep 23, 2014
    Messages:
    346
    Likes Received:
    3
    ESC Or bad motor.
    Switch 2 motors and fire up the bird and you wil know whether it is the esc or motor.
    Please keep us posted.
     
  4. hionbusa

    Joined:
    Nov 14, 2014
    Messages:
    112
    Likes Received:
    11
    Do you live in a no fly zone or height restricted area ?
     
  5. Eason

    Joined:
    Nov 13, 2014
    Messages:
    4
    Likes Received:
    0
    I 've replaced the new ESC and motor :(
    even swap output form m4 to m2 with jumper on naza
    the same situation :cry:
    i always played in RC flying field , not in any restricted area

    bad motherboard ??? i think ...
     
  6. CityZen

    Joined:
    Oct 22, 2014
    Messages:
    940
    Likes Received:
    36
    Location:
    NYC
    Do you actually have any problems flying?

    If not, then all you've got is two different revisions of ESCs. The older ones have the 4 extra beeps and different lighting timing. Maybe different idle speed too?
     
  7. Eason

    Joined:
    Nov 13, 2014
    Messages:
    4
    Likes Received:
    0
    No problems when flying...
    The rear-right ESC's version is v2 , same as others...
    In Fact , i had replaced old ESC to compare , but lead to the same situation ...
     
  8. aartsf

    Joined:
    Sep 23, 2014
    Messages:
    346
    Likes Received:
    3
    When you swape m2 and m4 at the naza connection and it is still the original motor that stays behind, the issue is not on the motherboard or naza, but in the motor itself or its esc.