Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

What would cause this topple over?

Discussion in 'General Discussion' started by dhazard, Jul 16, 2013.

  1. dhazard

    Joined:
    Jul 16, 2013
    Messages:
    3
    Likes Received:
    0
    Was working perfectly fine, brought it inside to unload video from card. Brought it back out and now it wont take off and topples over to front right. Obvious answer would be more power to the other three engines or that one being underpowered? What else might it be? Solutions?

    http://www.youtube.com/watch?v=De4QvmRgNrE
     
  2. BruceTS

    Joined:
    Jun 8, 2013
    Messages:
    304
    Likes Received:
    3
    Location:
    Granada Hills CA
    Battery fully charged?

    Hook it to the Naza assistant and do a calibration and at the field reset compass
     
  3. GeneL

    Joined:
    Apr 19, 2013
    Messages:
    104
    Likes Received:
    1
    Location:
    Northern California
    In my experience, if the skids grab the take-off surface even just a little, the Phantom will not take off vertically. It will topple, or nearly topple over to the side that is resisting. Go to a level, smooth, hard surface and try it again.
     
  4. woodlandsolutions

    Joined:
    Jul 14, 2013
    Messages:
    4
    Likes Received:
    0
    It seems to be that expectations are way high with these Phantoms. Folks need to learn how to fly properly first on a mini helicopter or the like.

    That sort of rookie mistake soon becomes eliminated. I'd never dream of buying a new 1k helicopter and letting it loose at height and to distance straight away!

    Fly safe!
     
  5. tanasit

    Joined:
    Jan 28, 2013
    Messages:
    554
    Likes Received:
    2
    I would follow BruceTS suggestion first. The compass is very sensitive and may be off if you walked pass the speakers or any magnetic field. In my case I put it in the back of my hybrid car near the traction battery and the compass needed to be recalibrated.

    Make sure also that you take off in ATTI mode.
     
  6. dhazard

    Joined:
    Jul 16, 2013
    Messages:
    3
    Likes Received:
    0
    I connected to the Naza assistant and upgraded the firmware, reset and made sure the batteries were fully charged. One of those things worked :) Now I have a new issue - video soon :)