Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Weak transmission - Broken?

Discussion in 'Pro/Adv Discussion' started by Google, Sep 6, 2016.

  1. Google

    Joined:
    Aug 3, 2016
    Messages:
    13
    Likes Received:
    0
    I have now for 3 weeks a phantom 3 Advanced and it's working great.
    I bought it from an another owner that used it only 19 flights, Most of the flights was before house just takeoff.

    When I go over 800m (Open field) the aircraft got weaksignal and disconnect, When I go to a field in the city and go up to 200m it also disconnect.

    How to fix this?

    • Antennas is in good position.
    • Drone is flying good.
     
  2. ElGuapo

    Joined:
    Jul 18, 2016
    Messages:
    524
    Likes Received:
    138
    Location:
    Burbank, CA
    First check what firmware is currently installed in the aircraft and the controller.
    I saw a thread of someone having the same problem and fixed it by downgrading the firmware to 1.08 and rebinding the remote controller to the drone. The rebinding process is not complicated at all.
    Also try setting HD stream to manual mode and select a channel that has the least interference and decrease quality to 4mbps.
     
    #2 ElGuapo, Sep 6, 2016
    Last edited: Sep 6, 2016
  3. Reed L

    Joined:
    Sep 13, 2015
    Messages:
    1,270
    Likes Received:
    390
    Location:
    Alta, Ca.
  4. Reed L

    Joined:
    Sep 13, 2015
    Messages:
    1,270
    Likes Received:
    390
    Location:
    Alta, Ca.