Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Weak RC Signal on Startup

Discussion in 'Pro/Adv Discussion' started by Nstrong48, Oct 18, 2015.

  1. Nstrong48

    Joined:
    Sep 23, 2015
    Messages:
    173
    Likes Received:
    20
    Location:
    Milan, MI
    Just got a new P3A this week directly from DJI. The RC is having trouble fully connecting to the bird. It will connect but I am getting a weak RC signal(2-3 bars). I have to reset the controller sometimes several times before the issue corrects.

    I am 99% certain it has nothing to do with how close or far away I am from the bird or how the antennas are pointing? Once the issue is corrected it flies just fine. I am worried that this will only get worse until I can't fly it anymore

    1 thing that I noticed is that the bird was named inspire. During the activation process I got several failed activation attempts before it ol went through and when it did it did not correctly give the name to the P3 that I told it to

    Anyone else ever have this issue?
     
  2. nickyb

    Joined:
    Sep 13, 2015
    Messages:
    391
    Likes Received:
    97
    Location:
    Northern Hemisphere
    If I was you I would ask for a replacement, just in case they used it as a testbed or something, maybe parts or component had come from a different production line. Im sure you are within your rights as a consumer, and I think this thing will just keep bugging you....best to start afresh!
     
  3. RoyVa

    Joined:
    Apr 10, 2015
    Messages:
    2,246
    Likes Received:
    449
    Location:
    Virginia
    Get it taken care of now while it's new. You don't need issues with anew bird.
     
  4. Nstrong48

    Joined:
    Sep 23, 2015
    Messages:
    173
    Likes Received:
    20
    Location:
    Milan, MI
    Sounds like a plan, just opened a support ticket. Just went and tested out the distance and went 2 miles stock. so definitely just a pairing issue
     
  5. normr

    Joined:
    Jan 8, 2016
    Messages:
    346
    Likes Received:
    56
    This morning when I was setting up to fly, I was getting weak tx signal warnings in red and it kept fluctuating between that and safe to fly, changing location didn't help, adjusting antennas didn't help, any ideas? Everything was fully charged.
     
  6. Nstrong48

    Joined:
    Sep 23, 2015
    Messages:
    173
    Likes Received:
    20
    Location:
    Milan, MI
    I never did get my issue fixed although it has never gotten worse or better. I just have to restart the remote sometimes to get it to correct itself. Basically when it isnt working i have 3 bars for the remote. It will never get better and only restarting it fixes it.