Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Vision issues

Discussion in 'Phantom 2 Vision Discussion' started by wat17, Feb 21, 2015.

  1. wat17

    Joined:
    Dec 17, 2013
    Messages:
    292
    Likes Received:
    4
    So I have brought my Phantom Vision (original no gimbal) out of retirement. It has a GPS issue due to a previous incident. I will be happy to fly it atti mode.

    Now when I start her up she flashes yellow slowly to represent atti mode, but the motors wont start. All controls seems to working in the assistant software.

    Interesting I cannot activate a compass calibration by moving the S1 switch numerous times, however when looking at the assistant software the switch moving is detected fine.

    Any thoughts? I did an advanced calibration with software and no change.
     
  2. crash1sttime

    Joined:
    Oct 31, 2014
    Messages:
    926
    Likes Received:
    74
    Location:
    Manchester UK
    Did ya calibrate the controller ? I had that happen last week and a calibration if the TX cured it
     
  3. wat17

    Joined:
    Dec 17, 2013
    Messages:
    292
    Likes Received:
    4
    Yes. Calibrated controller as well. Still no luck.
     
  4. crash1sttime

    Joined:
    Oct 31, 2014
    Messages:
    926
    Likes Received:
    74
    Location:
    Manchester UK
    Ok did ya calibrate in the RC asst and then in the phantom assistant software.
     
  5. wat17

    Joined:
    Dec 17, 2013
    Messages:
    292
    Likes Received:
    4
    I have now. Still having issues. I am getting a new LED error message though. It flashes red 5 times when I CSC. Looking through the manuals, I am still lost at what could be wrong.