Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Vision App not recognising battery or satellites

Discussion in 'Phantom 2 Vision + Help' started by j4mbo, Feb 27, 2015.

  1. j4mbo

    Joined:
    Feb 27, 2015
    Messages:
    3
    Likes Received:
    0
    Hey guys,

    New owner here so sorry if this is a stupid question.

    My DJI P2V+ was working fine for a couple of days. This morning I turned it on and now both the battery symbol and the satellite symbol are greyed out on my phone, even when the phantom is fully synced properly. The lights are also flashing green after the compass calibration, so i'm thinking that the phantom is successfully GPS paired, but it isn't telling my phone for some reason. I've tried re-installing the app but no change.

    Any help would be HUGELY appreciated.

    Thanks
     
  2. TuT

    TuT

    Joined:
    Nov 30, 2014
    Messages:
    130
    Likes Received:
    3
    Location:
    Sydney, Australia
    Is your WIFI extender on and charged?
     
  3. j4mbo

    Joined:
    Feb 27, 2015
    Messages:
    3
    Likes Received:
    0
    Unfortunately so...

    Any other ideas?
     
  4. billyv

    Joined:
    Jan 23, 2015
    Messages:
    1
    Likes Received:
    0
    Location:
    Oxford, MS
    Funny you posted this question, I had low altitude (3ft) crash yesterday and my app quit displaying the gps and battery level. This is my first post but I do read them from time to time, but this forum does have a lot of good information. So I search for this same problem and found out for one thing to look at is the four wire ribbon cable that attaches to the gimbal. That was the problem, when the bird hit the ground it jared the camera enough to pull all four of the wires out of the connector.
     
  5. Meta4

    Meta4 Moderator
    Staff Member

    Joined:
    Jan 8, 2014
    Messages:
    7,684
    Likes Received:
    3,419
    Check the three grey cables that come down from the Phantom and go into the gimbal base.
    Make sure they are all pushed in properly.
     
  6. j4mbo

    Joined:
    Feb 27, 2015
    Messages:
    3
    Likes Received:
    0
    Just wanted to say two of the wires were slightly loose, and I hadn't seen. Fixed it entirely!

    Thankyou!