Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Video transmission mess up on P3A/Autopilot/iPad Mini 2

Discussion in 'Pro/Adv Discussion' started by Mo of Pocatello, Apr 11, 2016.

  1. Mo of Pocatello

    Joined:
    Apr 2, 2015
    Messages:
    84
    Likes Received:
    4
    I tried Autopilot for the first time today, in Waypoint Mode. I flew a P3A using the penultimate firmware (didn't do the very recent upgrade), and an iPad Mini 2, with the latest OS. The flight was fine but the video transmitted back in realtime was totally messed up. Why is that, and how do I fix it? Thanks!!!

    Also, the camera pointed at me the whole time. How do I change the settings for that? Thanks!
     
  2. J&L

    J&L

    Joined:
    Jan 7, 2016
    Messages:
    334
    Likes Received:
    49
    You may have your focus strategy selected for "device" and not subject or something else which is why the camera was pointed at you. As for video I have seen my iPad mini 2 screen get pixelated but it's only for a few seconds. But when viewed on my computer using sd card the video was perfect. I have same setup you have. P3A, autopilot and IPad mini 2 w/cellular
     
  3. Mo of Pocatello

    Joined:
    Apr 2, 2015
    Messages:
    84
    Likes Received:
    4
    Thanks for your reply! I'll check my "focus strategy" next time. As for the messed-up video, it's not just pixelation. The video looked like an out-of-tune TV from the raster-scan days - pretty incomprehensible.
     
  4. J&L

    J&L

    Joined:
    Jan 7, 2016
    Messages:
    334
    Likes Received:
    49
    Is this video right off the sd card viewed on the computer? Just remember that the video coming back to the iPad is 720p and not 1080p so it will not look as sharp as your used too. Should look good when viewed on the computer
     
  5. Mo of Pocatello

    Joined:
    Apr 2, 2015
    Messages:
    84
    Likes Received:
    4
    Hi,

    The video that came back wasn't just low res. A proper 720p video would have been more than good enough. The video that came back was totally incomprehensible. It wasn't a resolution problem. The recorded video, from the sd card, was fine.

    Anyway, maybe if I turn everything off, let things rest, then turn everything on again, it'll all be fine. We'll see. Thanks!


     
  6. Mo of Pocatello

    Joined:
    Apr 2, 2015
    Messages:
    84
    Likes Received:
    4
    Today I opened up Autopilot again. I tried to set it to look ahead, in the same direction as the flight, but didn't find that mode. Running out of time, I flew with Litchi instead.
     
  7. Mo of Pocatello

    Joined:
    Apr 2, 2015
    Messages:
    84
    Likes Received:
    4
    Also, my iPad Mini 2 just has wifi, no cellular. When I bought it I didn't know how important it was to have cellular! My cell phone is a Galaxy S4 - too slow to fly with and get good video downlink.
     
  8. dragonmuzz

    Joined:
    Jan 2, 2016
    Messages:
    136
    Likes Received:
    20
    Location:
    andover
    i have a ipad mini 2 wifi and ive never had an issue yet in 104 flights.picture has always been 720p.
    i pre cache maps before hand or just link my ipad to my galaxy s6 edge plus so it gets data that way
     
  9. J&L

    J&L

    Joined:
    Jan 7, 2016
    Messages:
    334
    Likes Received:
    49
    Do you not have these menus? Maybe you need to play with the focus strategy in real time but you shouldn't have too. Try using target mode and using Mark as your focus point. Autopilot is very technical IMO but very worth while. As I feel confident using it I still refer to the videos and manual with every flight 9 times out of 10

    image.png

    image.png
     
  10. Mo of Pocatello

    Joined:
    Apr 2, 2015
    Messages:
    84
    Likes Received:
    4
    Thanks so much! I figured it out. I was in "basic" mode, and needed to be in one of the two more advanced modes to get the required settings.