Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Video Signal Gets Laggy and Choppy

Discussion in 'Pro/Adv Discussion' started by fhagan02, Jun 10, 2015.

  1. fhagan02

    Joined:
    Dec 1, 2014
    Messages:
    415
    Likes Received:
    332
    At take off the video signal is smooth, clean and for all intent and purpose it's in real time. After about 8 to 10-ish minutes it starts artifacting, bands of black and about a terrible 2-3 second lag in time. After this issue "initiates" it pretty much stays that way - at 500 feet away or 10 feet away - until the battery is exhausted. The last 3-4 flights in completely different locations the same thing keeps happening. A clean line of sight at all times. Repositioning antenna angles (flat sides always to the Phantom) doesn't seem to help. I've not messed with the custom signal settings for the feed yet. Don't know what the heck to "do" there anyway. Don't recall this happening when I first got the P3 a week ago but perhaps I was too excited to take note? Regardless, this is making me absolutely nuts.

    Any suggestions are warmly welcome.

    • Latest firmware on the Phantom and Controller
    • Latest version of the Pilot App
    • iPad Mini 2: 34GB (18GB available), Wifi Only, Airplane mode always
     
  2. VoicOfReason

    Joined:
    Aug 29, 2014
    Messages:
    489
    Likes Received:
    129
    My Ipad Mini 2 did that as well. Don't worry, you're not the only one. It's been said many times it very may well be partly an overheating issue. See if you can let your iPad cool down or take it out of the case.
     
  3. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,413
    Likes Received:
    567
    Location:
    Sydney Australia
    A few things to consider...

    In DJI app > change to a selected channel instead of AUTO.
    Disable Caching in the app.
    On your ipad, enable hardware decoding.

    I've heard about overheating issues on the ipad that causes choppy fpv. Weather can affect it. If your Ambient temps are hot, then it will like hardware on your ipad work overheat.
     
  4. fhagan02

    Joined:
    Dec 1, 2014
    Messages:
    415
    Likes Received:
    332
    Thanks a bunch and....
    Ohhhhhhh man. I made a sun shield out of 1/4 inch black foam core. (About 3 or 4 flights ago) My iPad sits flat in it like sitting in the bottom of a black box with a lip around it. I should probably cut vent holes all over the back?

    If I disable the video cache will my flight records and realtime playback of the flight and controls still be saved? I could care less about the cached video but I would want all the flight data incase I ever have and "incident."

    iPad oven attached....

    IMG_6469.jpeg
     
    #4 fhagan02, Jun 10, 2015
    Last edited: Jun 10, 2015
  5. Phantom751874

    Joined:
    Mar 13, 2015
    Messages:
    995
    Likes Received:
    269
    The cached video can be important if you lose your P3 and can't find it. It can be used to find your P3 or as evidence along with your flight data that the P3 had a malfunction and went down etc. I wouldn't disable caching I'd just clear it but keep it on. As was stated make sure hardware decode is ON as well. And watch the outside ambient temps. Try to fly while standing in shade and it helps If there's some wind. The tablet overheating deal seems to be real.
     
    fhagan02 likes this.
  6. AdamBaron

    Joined:
    Jun 11, 2015
    Messages:
    10
    Likes Received:
    1
    I was just about to post the same problem when I stumbled across this thread. I am having this issue too except I am using the android version on a Note 4. Really poor frame rates. It seems that this just started happening. Maybe this came with the new firmware update? Sucks...
     
  7. Coldfire

    Joined:
    Feb 8, 2015
    Messages:
    203
    Likes Received:
    90
    It's not heat with the note 4. It was 60 degrees at night. Phone was cool.

    I was in airplane mode. Restarted note 4. Started flying. 10 min in it starts to lag... grrrr. I bring the bird back and land. Restart the app.. take off, I'm still lagging.
    I bring the bird back and land. Restart the phone and take off. Zero lag for the rest of the flight.

    This is a new issue as I few for 2 weeks without any lag. Very frustrating.
     
  8. Pigsnuck

    Joined:
    Apr 28, 2015
    Messages:
    18
    Likes Received:
    1
    I started having choppiness issues when Android upgraded from 5.1.0 to 5.1.1 on my Nexus 5. Did you upgrade Android? I just tried flying with my iPhone 6, and there is no choppiness, so it is definitely related to Android (for me).
     
  9. Coldfire

    Joined:
    Feb 8, 2015
    Messages:
    203
    Likes Received:
    90
    I'm at 5.1.0
     
  10. Pigsnuck

    Joined:
    Apr 28, 2015
    Messages:
    18
    Likes Received:
    1
    OK, then that's not the reason for you. Did turning off caching help your issue?
     
  11. Coldfire

    Joined:
    Feb 8, 2015
    Messages:
    203
    Likes Received:
    90
    I believe cleaning it helped. I would prefer not to turn it off.
     
  12. Pigsnuck

    Joined:
    Apr 28, 2015
    Messages:
    18
    Likes Received:
    1
    OK, thanks for the tip. I will try that too, then.
     
  13. Coldfire

    Joined:
    Feb 8, 2015
    Messages:
    203
    Likes Received:
    90
    Have you had a chance to try it. Worked for me yesterday.
     
  14. Pigsnuck

    Joined:
    Apr 28, 2015
    Messages:
    18
    Likes Received:
    1
    It worked for a little while, then got choppy again. I actually turned the local caching completely off, so maybe the phone is overheating or something. It is working better than it was, that's for sure.
     
  15. Coldfire

    Joined:
    Feb 8, 2015
    Messages:
    203
    Likes Received:
    90
    Hummmm... I know my phone wasn't over heating. It was only 60 degrees out and my phone was cool to the touch.
     
  16. mtnmaddman

    Joined:
    Mar 1, 2015
    Messages:
    73
    Likes Received:
    20
    Almost everyone is experiencing this problem the problem is worse on android if you have upgraded to lollipop the java that the program is using is looping it eventually balls everything up and overloads the processor the looping is causing the processor to overheat and eventually to crash I have 2 tab s's one just reset by the samsung factory repair to 4.4.2 kit kat I have been working with samsung the past week with this problem mainly the wifi direct problem as I am the developer designer of the nebula alien sunglasses fpv system for the phantom in cases of no hdmi my glasses connect using wi fi direct. the tablet that has been reset to kit kat has none of the samsung crap or anything else in it no updates or anything else it works perfect no loading up full flights 20 min. same at beginning as at end with the video also being flowed to my glasses wirelessly the tab s with the lollipop upgrade starts loading immediately its unusable the wifi direct is also crashing while the pilot app is running in lollipop and not in kit kat this is an app problem that likely will be cured soon, I am more concerned about the barometric (altitude) pressure sensor that is also balling up check it out the next time your landing look at the altitude reading at ground level.
     
  17. CloudsNeverDie

    Joined:
    Jan 26, 2015
    Messages:
    227
    Likes Received:
    60
    Me too, you are not alone. Worked fine on the older version of the firmware and app. DJI broke something with the latest update.

    A tip - on iOS devices, you can temporarily get rid of the lag by hard closing the app (press Home button, then double press Home button, swipe away DJI Pilot window, then reopen DJI Pilot app). You can do this safely even while the bird is in the air.
     
  18. Javy871

    Joined:
    May 3, 2015
    Messages:
    6
    Likes Received:
    2
    Subscribed. Same problem on note 4.

    Sent from my SM-N910T using Tapatalk
     
  19. offthefront

    Joined:
    Jan 11, 2015
    Messages:
    102
    Likes Received:
    24
    Location:
    Northeast Florida
    same ...... Samsung Tab S ...... was perfect before ........ showed 54' Alt after Landing