Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

video relay suddenly stopped

Discussion in 'Phantom 2 Vision + Discussion' started by RaleighVision+, Sep 13, 2014.

  1. RaleighVision+

    Joined:
    May 13, 2014
    Messages:
    11
    Likes Received:
    0
    Location:
    Raleigh, North Carolina
    The last time I flew my helicopter I was getting intermittent video relay and now it's just flat out not relaying any feed at all. I opened it up and checked all the connections. The camera works fine and the gimbal controls are fine also, just no feed. I also uninstalled and reinstalled the app and re binded the camera. Any suggestions?
     
  2. photographix

    Joined:
    Aug 7, 2014
    Messages:
    71
    Likes Received:
    3
    Location:
    Albuquerque, New Mexico
    Sounds like you did everything possible. The only thing I would suggest it to make sure the top of the WiFi range extender is pointed in the general direction of the Phantom. I had mine pointed straight up and had a very skippy video downlink, and it would drop the signal entirely if the Phantom was more than about 100 ft away.
     
  3. RaleighVision+

    Joined:
    May 13, 2014
    Messages:
    11
    Likes Received:
    0
    Location:
    Raleigh, North Carolina
    thanks for the suggestion. I took it to a electronic repair shop (who knew one existed) near my house and the dude was very helpful. He pointed out that the ribbon which connects to the HD Video downlink to the camera/gimbal had a nick in it. Undoubtedly caused by the lousy repair job @DJIGlobal earlier in the summer.

    Now I'm just trying to figure out how to get a replacement ribbon without sending my aircraft out for a 4 week repair!