Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Video problem - hmmm...

Discussion in 'Phantom 2 Vision Discussion' started by happydays, Feb 11, 2014.

  1. happydays

    Joined:
    Jul 5, 2013
    Messages:
    1,852
    Likes Received:
    661
    Location:
    Warrenpoint, Ireland
    Shot a short clip tonight of some runners at a local track. Not great footage cos it was windy.

    Got home, took the micro SD card out of the P2V, put it into an adapter and into the mac - nothing there, nada. Back into the vision, hooked up to the iPad again and there it is. Transferred to the iPad using the DJI app.

    Back into the adapter and in to the mac again - nothing. Switched over to windows - there it is, an MP4 file. Won't play in Windows Media Player though. Back to the mac and there it is, however it won't play on any application, Quick Time, VLC, Flip Player, DIVX. Nothing.

    Any ideas?

    Connor
     
  2. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
    Can you remember if you stopped the recording before you landed, or did you just shut down with the camera running?
     
  3. GMANNZ

    Joined:
    Jan 24, 2014
    Messages:
    405
    Likes Received:
    1
    Location:
    Wellington, New Zealand

    All I could suggest is a reformat and retest .... have seen SD card issues jumping between OS giving probs, also have seen some reports as Pull_up indicates in closing off of camera while still running which somehow corrupts current recording and/or ultimately the entire mem card itself ... somethreads have covered this, where people have had results in starting P2V again and shutting camera down, which in some cases has closed off file and then access restored.

    Any issues I always try and recreate same fault scenario with different media to start with ... if same issue shows, is more than likely not the media itself, but something else in the device or transfer with external OS handling.

    Apple forums do seem to show some issues with this type of scenario ... might need some deep seacrching and isolation test to work out what exactly is happening .... other MAC users may be able to advise further ..
     
  4. dastagg

    Joined:
    Jun 7, 2013
    Messages:
    184
    Likes Received:
    3
    Location:
    Southeast Texas
    I have had files to be there but would not play a few times and shut down video recording properly but still didn't play. I put back in camera and turned everything on and found video and processed from app, then video would play just fine from the card in computer after that. Only did it a couple of times and made sure I stopped recording but still did it a couple of times. Most of the time, it worked just fine from the card. Guessing it didn't finalize properly gefore I turned everything off after recording. Not sure, but was always able to recover video using app remotely from card in camera. Maybe just turning on and off again would work also, haven't tried that yet since it hasn't happened often. I 'm sure I did something different, just haven't caught when it happens as to difference.
     
  5. happydays

    Joined:
    Jul 5, 2013
    Messages:
    1,852
    Likes Received:
    661
    Location:
    Warrenpoint, Ireland
    Good point - can't remember the exact sequence of close down. I think I may have stopped the Phantom before stopping the recording but honestly can't remember. At least it was discardable footage!

    Must remember to stop recording first in future. To be honest, it was so windy I was just glad to get the P2V back to a position where a grab landing could take place that I probably didn't stop the video recording.

    Thanks for the answers!

    CBS
     
  6. LeoS

    Joined:
    Nov 25, 2013
    Messages:
    747
    Likes Received:
    1
    Everytime I stop the phantom before stopping recording, that happens. The resulting file usually has a date of Jan 1 2008 (or some such) and unplayable until it's reconnected back to Phantom for it to close the file.
     
  7. dave21

    Joined:
    Jan 16, 2014
    Messages:
    138
    Likes Received:
    0
    Put your card back to phantom and switch it on. Wait 30 sec and shut it down again. Someone wrote it helped to correct the file, lets say finalize it.
     
  8. happydays

    Joined:
    Jul 5, 2013
    Messages:
    1,852
    Likes Received:
    661
    Location:
    Warrenpoint, Ireland
    I'll try that later. Doesn't matter too much as the footage was all wobbly!
     
  9. happydays

    Joined:
    Jul 5, 2013
    Messages:
    1,852
    Likes Received:
    661
    Location:
    Warrenpoint, Ireland
    Update

    Tried all the above - same result. Tried formatting the card via the app, shot some stills and video inside, replaced in mac - nothing there except the old files! Strange!

    Deleted everything from the card on Mac - reformatted on the app and everything is now working again.

    Strange - just need to keep the memory cards clean in future!

    Thanks for the tips guys - if only the weather here would improve so we could get out flying!

    C