Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Video lag 3-5 seconds since 1.8

Discussion in 'Pro/Adv Discussion' started by GodFear17, Jul 4, 2016.

  1. GodFear17

    Joined:
    Dec 31, 2015
    Messages:
    171
    Likes Received:
    64
    Location:
    Pasadena Texas
    So I've had this weird video lag issue, basically lots of video drop outs, and the video is lagged behind anywhere from 3-5 seconds ever since the 1.8 firmware. I know others have had this issue.

    Running on iPad mini4 everything updated to latest

    It's not the iPad lagging my iPhone 6s+ does the same thing and any other device I try. Something going on with the bird.

    So messing around I noticed if I switch from NTSC to PAL it actually started working right... For a little bit. This also does a full reset on the camera. Then once the lag starts switching it again seems to fix it for a few mins.

    Everything was great until 1.8.

    Any ideas?

    Notes: all the normal settings are right, not recording locally, etc etc I've got over 27hrs flight time. I've reinstalled, I've ran out of ideas


    Not
     
  2. flyNfrank

    Joined:
    Feb 1, 2014
    Messages:
    4,212
    Likes Received:
    910
    Location:
    Indy, USA
    I've been through this issue as well as many others over time. Most do not want to except what the issue is so they spend a lot of energy running around in circles like a dog chasing it's tail. But even though they don't want to admit it, they eventually realize the issue is what they were 1st told from the get-go.

    Each firmware update has the possibility to add more processes to the app. The problem is we never know about it until our devices begin showing signs. And that's where you are likely at now. I had to buy a new tablet. My new Nvidia K1 Shield took care of everything. No more issues whatsoever.

    Edit: I forgot to add that I was one of those who wouldn't except my tablet was the problem, that it no longer had enough resources to properly function with the GO app.
     
    #2 flyNfrank, Jul 4, 2016
    Last edited: Jul 4, 2016
  3. No_Fly_Zone

    Joined:
    Jun 12, 2016
    Messages:
    21
    Likes Received:
    3
    Same here I have an iPad Air that I use exclusively for my Phantom, nothing else. No more issues


    Sent from my iPad using PhantomPilots mobile app
     
  4. GodFear17

    Joined:
    Dec 31, 2015
    Messages:
    171
    Likes Received:
    64
    Location:
    Pasadena Texas
    I don't know if you read my post or not, but I'm running on a dedicated iPad mini 4, and my backup is a iPhone 6s Plus, so I have a A8 and A9 CPUs to test with. Lol how much newer can you get?

    I know for a fact GO runs fine on a mini 2 lol and your trying to tell me I need to upgrade from a mini 4? I'm just going to take it as you didn't read the post.

    I have tried running on several devices and it all acts the exact same way. Inside and 70 degrees so it's not an over heating problem. Actually gets a little better outside at 100feet up but still is 3-4 second lag.


    Sent from my iPhone using PhantomPilots mobile app
     
  5. GodFear17

    Joined:
    Dec 31, 2015
    Messages:
    171
    Likes Received:
    64
    Location:
    Pasadena Texas
    iPad mini 4 has a better cpu than air, the air2 has A8X cpu and the mini4 has A8. Lol I don't think it's a cpu issue because my iPhone 6s Plus with a A9x cpu is doing exactly the same thing.


    Sent from my iPhone using PhantomPilots mobile app
     
  6. BrandAL

    Joined:
    Apr 18, 2016
    Messages:
    105
    Likes Received:
    21
    That makes no sense! How can the app be the problem. Even if it did add more "processes" or threads how ever technical you want to get. The iPad processor should be able to handle. I think is more than issue with video transmission hardware on the gimbal. I had the same problem. Basically same second lag and I took it to a drone store and they tried diff iPad and diff RC and same problem. You will literally wave at the drone and you didn't see it replay way after. So they ask me if I exposed the drone to a lot of heat and I said I left it in the car one day and it was scorching hot outside. So maybe these cheap China made electronics can't handle so much heat.

    So I went out of my way and said screw it. Not going to wait 3 weeks plus for DJI to repair my drone and I bought a gimbal and camera assembly. I switch it out and Right away zero lag.

    Mind you I reverted back to 1.7 FW before thinking it was that. So stayed at 1.7 and DJI go app 2.7.2. My RC is updated to latest version.


    Check my videos at the time and compare if same as yours
    Serious Video feed lag on my P3A. help!



    Sent from my iPhone using PhantomPilots mobile app
     
  7. flyNfrank

    Joined:
    Feb 1, 2014
    Messages:
    4,212
    Likes Received:
    910
    Location:
    Indy, USA
    Nobody said the app was the problem. If the app were the problem, then everyone would be experiencing the same issue. It clearly takes time to diagnose a problem, and when you don't have the aircraft in front of you, you only have what details are given to go by.

    So the OP says the issue never took place until after a firmware update. What would make you think there was a hardware issue from a change to the software? My situation was the same as the OP's. I had zero issues until a firmware update. With tweaking I could make little improvements but never a cure.

    I did not read through the OP's before posting the 1st time. Had I noticed he was using a ipad mini 4 I would not have mentioned the resource possibility in the device. In my opinion at this point this will be a guessing game on what the problem might be.

    My next suggestion would be the 32 channel mod and look for improvements.
     
  8. BrandAL

    Joined:
    Apr 18, 2016
    Messages:
    105
    Likes Received:
    21
    Yup and also try to revert one FW version and see if it helps.


    Sent from my iPhone using PhantomPilots mobile app
     
  9. Jesse James

    Joined:
    Apr 27, 2016
    Messages:
    236
    Likes Received:
    45
    You have the stock sd card ?


    Sent from my iPhone using PhantomPilots mobile app