Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Video is black after upgrade

Discussion in 'Phantom 2 Vision + Discussion' started by PhantomPhyler, Aug 2, 2014.

  1. PhantomPhyler

    Joined:
    May 9, 2014
    Messages:
    25
    Likes Received:
    0
    Location:
    Holt, MI
    So...my DJI Vision app on my Verizon Galaxy S4 updated to V1.0.52 and said the bird needed updating as did the Phantom 2 Vision Assistant. On my WIn 7 machine, I downloaded Vision Assistant 3.2, which then updated the bird with V3.06 for the autopilot system and V1.0.1.32 for the central board. Nothing else showed updates available.

    All the updates went fine and I fired her up. The new app worked fine - got the new battery monitor across the top and such. The bird flies fine - no changes there. But...and this is the big one - I get no video. Nothing. Just a black screen with the flight telemetry overlaid. I can tilt the gimbal, I can take photos and video, although I have no idea what I am pointed at, as I have no FPV on my phone.

    No crashes, or anything like that. Everything worked fine before the updates. And since the updates, the only thing that stopped working is that I get no video.

    I checked in the app and it binds properly to the camera. It must, or I wouldn't be able to take photos or move the gimbal. I tried all four video quality settings with the same result. Black screen.

    I deleted the android app and reinstalled it. I forced the Assistant software to reinstall the firmware upgrades on the bird, and still, nothing.

    Anyone have any thoughts on what is going wrong?
     
  2. flyNfrank

    Joined:
    Feb 1, 2014
    Messages:
    4,211
    Likes Received:
    907
    Location:
    Indy, USA
    I don't know. But I also had that happen after v3.06 firmware upgrade. My video restored after rebooting the quad. My upgrade at that time was with v1.0.1.31. The v1.0.1.32 took place yesterday afternoon.

    I feel like the issue is app related, and could be something very minor. I read where people were not allowed to create DJI accounts over the weekend and until monday. This could be something such as not communicating with the DJI server, or not in sequence? I really don't know. Had mine not come back on when it did to where I would have had to spend more time on it then I could be of more help. I have a feeling it will fix itself and you will never know what the cause was. Btw, I'm almost positive it takes having a wifi connection before the video stream will start.
     
  3. vortigern

    Joined:
    May 28, 2014
    Messages:
    163
    Likes Received:
    3
    I had the same thing no video , recording and control worked fine however. On rebooting everything the video link is back. A minor glitch probably.
     
  4. Meta4

    Meta4 Moderator
    Staff Member

    Joined:
    Jan 8, 2014
    Messages:
    7,695
    Likes Received:
    3,425
    Same symptoms but mine was cured by uninstalling the app and reinstalling it.
     
  5. PhantomPhyler

    Joined:
    May 9, 2014
    Messages:
    25
    Likes Received:
    0
    Location:
    Holt, MI
    Interesting. I have uninstalled and reinstalled the app, rebooting my phone in between. I have not tried it again after force-updating the bird again. I powered off the bird multiple times in the process. I assume that's what you mean by rebooting, unless there is another process I am not aware of other than turning off the battery.

    I will try one more time and then try uninstalling and reinstalling the app on my phone. Thanks for all the input.
     
  6. 8676309

    Joined:
    Jul 6, 2014
    Messages:
    29
    Likes Received:
    0
    Anyone have the APK for Android to downgrade to the previous version? FPV is very unreliable with this new version. I get freezing video all the time, even with the quad closeby and out in the countryside away from interference. I flew in the same place a couple weeks ago before the update and went out 2500ft before losing FPV.
     
  7. 8676309

    Joined:
    Jul 6, 2014
    Messages:
    29
    Likes Received:
    0

    Oh yeah, and I didn't update the firmware yet. Maybe that is a problem?
     
  8. 8676309

    Joined:
    Jul 6, 2014
    Messages:
    29
    Likes Received:
    0

    Nope, just tried 3.06. Shoddy FPV continues. Anyone else?
     
  9. PhantomPhyler

    Joined:
    May 9, 2014
    Messages:
    25
    Likes Received:
    0
    Location:
    Holt, MI
    I uninstalled the app and reinstalled it - still no video.
     
  10. Double-D

    Joined:
    Jun 6, 2014
    Messages:
    319
    Likes Received:
    0
    Location:
    The Land Down Under
    Any luck restoring video feed?
    I'm holding off upgrading atm.
     
  11. PhantomPhyler

    Joined:
    May 9, 2014
    Messages:
    25
    Likes Received:
    0
    Location:
    Holt, MI
    No luck. I downgraded everything - nothing. Re-upgraded everything - nothing. Installed the Android app on my wife's phone - nothing. Called DJI yesterday - suggested re-binding the camera. Did that - nothing. So...official word from DJI? Send it in. Right now - four week turnaround. Yikes.
     
  12. BobUnplugged

    Joined:
    Nov 17, 2013
    Messages:
    235
    Likes Received:
    24
    Have you rebooted your PHONE? Not just turning the screen off and on, but REBOOTING. I know how to do it on an iPhone, but not an Android. Also, you may want to reset your network connections. You'll have to re-enter your passwords for your saved wifi connections.
     
  13. flyNfrank

    Joined:
    Feb 1, 2014
    Messages:
    4,211
    Likes Received:
    907
    Location:
    Indy, USA
    I have an extra brand new controller with range extender you are welcome to try if you want to drive to my house. South Bend looks to be the halfway point. I have a bad feeling though it could be the module so many others are having the replace now. Check this thread for more details:
    viewtopic.php?f=27&t=20006&p=182275&hilit=replace+module#p182275
     
  14. Mori55

    Joined:
    Feb 13, 2014
    Messages:
    1,993
    Likes Received:
    6
    Location:
    NJ-USA
    Mine did the same thing , only thing I could see on the screen was a grayed out image of whatever the camera saw before it happened. I screwed around and rebooted everything including my iPad mini.
    Eventually it started working.
     
  15. PhantomPhyler

    Joined:
    May 9, 2014
    Messages:
    25
    Likes Received:
    0
    Location:
    Holt, MI
    Nope - DJI gave me an RMA - getting ready to ship it to LA.
     
  16. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,409
    Likes Received:
    567
    Location:
    Sydney Australia
    There have been some users getting a positive result after freeing 3 gigs on their devices. I cant find the post.
     
  17. Double-D

    Joined:
    Jun 6, 2014
    Messages:
    319
    Likes Received:
    0
    Location:
    The Land Down Under
    Sorry to hear. Hope it gets turned around quickly.
     
  18. bpslm

    Joined:
    May 8, 2014
    Messages:
    11
    Likes Received:
    0
    Im getting the same thing on the latest iPhone app 1.0.42, everything works except fpv.
     
  19. nefarmboy

    Joined:
    Feb 1, 2014
    Messages:
    2
    Likes Received:
    0
    Something happened to my Vision this morning. Screen on iPhone was locked on last image before upgrade. Finally shut phone off and connected to IPAD and it worked. Shut IPAD off and restarted phone and everything was working again. Scary 15 minutes- thought I turned camera into a brick.
     
  20. Mori55

    Joined:
    Feb 13, 2014
    Messages:
    1,993
    Likes Received:
    6
    Location:
    NJ-USA
    Same hing happened to me on my iPad mini. Had to reboot it. Then it worked.