Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Standard Video feed is 4:3 when it was 16:9

Discussion in 'Phantom 3 Help' started by Biggunspaul, May 1, 2016.

  1. Biggunspaul

    Joined:
    May 1, 2016
    Messages:
    32
    Likes Received:
    1
    Hi all,

    I have had my drone a few months but only used it a few times and the last time was a couple of months back,I used it today and for some reason the video feed to my smart phone is in a 4:3 ratio where before it was 16:9,I have gone into the camera settings and changed the ratio in there and that changed the ratio of the image displayed in the 4:3 ratio if that makes any sense.The strange thing it I turned off the drone controller restarted everything and it was back to 16:9 as it should be,but now it's gone back to 4:3 again.
    So any reason to why this is doing it ? The only thing I can think of is the latest updates to the app and firmware are to blame.

    Also where has the YouTube live streaming feature gone as I can't seem to see it anymore on the app as it seems to have changed since I last used it .

    Thanks in advance.
     
  2. Malakai

    Joined:
    Feb 29, 2016
    Messages:
    183
    Likes Received:
    72
    Location:
    Wolves, UK
    change from camera mode to video mode ;)

    in camera mode the video feed is 4:3 in video mode the feed is 16:9


    Sent from my iPhone using PhantomPilots mobile app
     
  3. Biggunspaul

    Joined:
    May 1, 2016
    Messages:
    32
    Likes Received:
    1
    Yep I've done that and it doesn't make any difference.

    It records and take photos in 16:9 just fine,it's just the live feed.
     
  4. Malakai

    Joined:
    Feb 29, 2016
    Messages:
    183
    Likes Received:
    72
    Location:
    Wolves, UK
    double check the aspect ratio for both photo and video mode. try setting photo to 4:3 and video mode to 16:9 then in live view slide the slider between video and photo mode to see if that makes any difference. what tablet or phone are you using?


    Sent from my iPhone using PhantomPilots mobile app
     
  5. Biggunspaul

    Joined:
    May 1, 2016
    Messages:
    32
    Likes Received:
    1
    Ok I will give that a go when it's all finished charging.

    I'm using a Samsung Galaxy s6 edge plus,but I've also tried the dji go app on my iPad Pro just to see if it does it on that,and it doesn't.
     
  6. mdowney58

    Joined:
    Feb 15, 2016
    Messages:
    491
    Likes Received:
    114
    Location:
    Mountain City, TN
    Two or three Go app updates ago caused this for many users, including me.
    I solved it, but others said it didn't go away, but that was back in mid March.
    There's been 2 updates since then I think.
    For me, a CLEAN reinstallation solved it.

    Sent from my SM-N910V using Tapatalk
     
  7. Biggunspaul

    Joined:
    May 1, 2016
    Messages:
    32
    Likes Received:
    1
    image.jpeg
    Just tried a few different settings and its still the same.
     
  8. Biggunspaul

    Joined:
    May 1, 2016
    Messages:
    32
    Likes Received:
    1
    Some more images.

    image.jpeg image.jpeg image.jpeg image.jpeg
     
  9. Biggunspaul

    Joined:
    May 1, 2016
    Messages:
    32
    Likes Received:
    1
    What do you mean by a clean reinstallation ? I have deleted and re installed the go app,but that hasn't helped.
     
  10. mdowney58

    Joined:
    Feb 15, 2016
    Messages:
    491
    Likes Received:
    114
    Location:
    Mountain City, TN
    I have witnessed bad behaving apps, and Go being one of them, where uninstalling, and reinstalling (no more, no less) provided no change, but then after following the below, these apps (including Go) began behaving.
    I'm using a Samsung Galaxy Note4, on Lollipop.
    1) Go into app manager, find the Go app, and clear cache.
    Then force stop the app.
    2) Un-install the Go app.
    3) Shut device off for a minute.
    4) Turn device on, and reinstall Go app.




    Sent from my SM-N910V using Tapatalk
     
  11. Malakai

    Joined:
    Feb 29, 2016
    Messages:
    183
    Likes Received:
    72
    Location:
    Wolves, UK
    This is what it looks like for me when i cycle ratios and modes. Are you saying its not doing this for you? I am using an iPad air though.



    Sent from my iPad using PhantomPilots mobile app
     
  12. Biggunspaul

    Joined:
    May 1, 2016
    Messages:
    32
    Likes Received:
    1
    Will try that now
     
  13. Biggunspaul

    Joined:
    May 1, 2016
    Messages:
    32
    Likes Received:
    1
    What mine doesn't do is fill the whole screen like yours does.

    Your live view can be seen underneath the controls for take off and camera controls,mine just has black bars either side and they stay there no matter what i change,and it was never like this the last time I used it a couple of months ago,the strange thing is it went normal again once today,but then went back again after it was all turned off and back on again.
     
  14. Malakai

    Joined:
    Feb 29, 2016
    Messages:
    183
    Likes Received:
    72
    Location:
    Wolves, UK
    Ok, if its working with your ipad then i would say the issue is with the android software. Unfortunately i only have IOS devices. Hopefully someone else on here can help you out. Good luck.


    Sent from my iPad using PhantomPilots mobile app
     
  15. Biggunspaul

    Joined:
    May 1, 2016
    Messages:
    32
    Likes Received:
    1
    Yes that's what I am thinking,shame the iPad Pro is too big to use mounted to the controller.

    Thanks anyway for your help
     
  16. mdowney58

    Joined:
    Feb 15, 2016
    Messages:
    491
    Likes Received:
    114
    Location:
    Mountain City, TN
    That is how mine looked (squished) after the March 14 Go app update, and there were threads here, and on the DJI Phantom forums also.
    The clean install the same day fixed it for me.
    But as I stated, if you search here and the DJI forum threads, you'll see there were a lot of users who claimed nothing solved it.
    I don't know if the 2 Go app updates since then resolved the problem for them or not, since I stopped following the threads.

    Sent from my SM-N910V using Tapatalk
     
  17. Biggunspaul

    Joined:
    May 1, 2016
    Messages:
    32
    Likes Received:
    1
    Thanks

    Don't suppose you know where abouts I would find those threads,sorry to ask but I'm new to the forum and it seems like a mine field
     
  18. mdowney58

    Joined:
    Feb 15, 2016
    Messages:
    491
    Likes Received:
    114
    Location:
    Mountain City, TN
    Sorry, I tried but came up empty here, searching both "16:9" or "4:3".
    I searched those same terms at the link below, and there are a few, but the one I remember was over 35 pages last time I was reading, and I don't see that one.

    DJI Phantom Forums

    Warning! Their forums are horrible. Unless there is a setting I'm missing, it's a bad design.

    Sent from my SM-N910V using Tapatalk
     
  19. Biggunspaul

    Joined:
    May 1, 2016
    Messages:
    32
    Likes Received:
    1
    Thanks very much for the link.

    I've had a look and found that it is the android app at fault.

    What happens is that whatever aspect ratio you have selected before you turn off the device is what aspect ratio it will be stuck on next time you turn it on.So I selected 16:9 and as normal it stayed in 4:3,I then tuned it all off and on again and sure enough it was then in 16:9.

    So it's not fixed as such but at least I have found a work around for now.

    Next question is,does the app still allow YouTube live stream as I can't seem to find it,I know it was there before the update.
     
  20. rdandy5875

    Joined:
    Apr 26, 2016
    Messages:
    86
    Likes Received:
    24
    Just wanted to bump this. I've been having the same problem with my P3S and now my P3A, the camera seems to feed the correct aspect ratio to the screen on my phone (galaxy s7), but I get black bars on the right/left, and the video is horizontally squeezed by as much as the black bars are wide, making everything look, well, squeezed horizontally.

    Determined to #1 measure the horizontal skew, and #2 get the issue on video, I set up a square on my basement door with tape, and recorded my screen. About 20 seconds into recording, the video feed glitched and the aspect ratio was then correct, filling the whole screen. I almost made a liar out of myself but the screen recorder captured the glitch. I dont know what was wrong or what I did if anything to correct it. I did have to go out of and back into DJI GO a couple times, etc, to set up the screen recorder. I first attempted to take a screenshot which didn't work, it kicked me out of the GO app. Maybe from exiting/entering the app, however the glitch occured mid-video stream, not upon re-entering the app. I also did just update the app to the latest version, initial install was last week. Hmmmm.

    Probably will come back next time I take it out to fly ;/

    Please excuse the light F-bomb mid-video....

     
    #20 rdandy5875, May 8, 2016
    Last edited: May 8, 2016