Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Advanced Upgraded to new 1.4 FW for P3A Success text shown

Discussion in 'Phantom 3 Help' started by AL T, Sep 13, 2015.

  1. AL T

    Joined:
    Apr 13, 2015
    Messages:
    117
    Likes Received:
    18
    Location:
    Henderson, NV
    Just got back from props off calibration on gimbal out side. Going thru most of the settings and when I brought up the "about" section, it showed fw 1.28+. I know I have the aircraft with 1.4 installed, as I checked the text file and it shows success. I also put it in "F" mode and it shows all the new features available. Also states, the aircraft has to be in the air to work. OK I understand that. My question is, do I have to get it airborne for the "about" section to change and show fw 1.4 IS installed? The RC shows fw 1.32.. Any advice would be appreciated.
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,054
    Likes Received:
    5,609
    Location:
    US
    The RC should show 1.3.2. 1.4 only installs on the Phantom.
     
  3. AL T

    Joined:
    Apr 13, 2015
    Messages:
    117
    Likes Received:
    18
    Location:
    Henderson, NV
    Yes on my ipad mini 2 under the about section it shows 1.28+ After upgrading and getting the success file, checked and verified on my pc with the 1.4 upgrade, I thought it should show 1.4 in the about section on the aircraft. I am dazed and confused, or am I just missing something obvious?
     
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,054
    Likes Received:
    5,609
    Location:
    US
    The aircraft version should appear in the About section of the DJI GO app when your remote controller is connected to the Phantom.
     
  5. AL T

    Joined:
    Apr 13, 2015
    Messages:
    117
    Likes Received:
    18
    Location:
    Henderson, NV
    Yes it does, however it shows 1.28+ not 1.4. It does allow me to bring up the new features available with the 1.4 fw.. but the updated GO app shows 1.28+ , in the "about" section.

    Thanks for your patience!
     
  6. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,054
    Likes Received:
    5,609
    Location:
    US
    I suppose 1.28+ is technically correct. You clearly do not have 1.28 installed though. Perhaps it's a bug in the DJI GO app.
     
  7. AL T

    Joined:
    Apr 13, 2015
    Messages:
    117
    Likes Received:
    18
    Location:
    Henderson, NV
    Good to hear 1.28 I guess the "plus" is another way of saying closer to 1.4!! I have been on this forum since feb 15 when I got my P2V+ver 3. I have been following the P3A adv forum since may 15 when I got my P3A. Due to medical issues I have yet to put the adv in the air.
    The information a "semi-noobie" like myself receives from this forum is near priceless.
    I greatly appreciate all the info given here. It is outstanding people like yourself that makes this forum A+.
    Thank You for for going the extra mile.
    Getting ready for the first flight with my P3A, soon.
    AL T