Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Upgrade needed?

Discussion in 'Pro/Adv Discussion' started by Chuck Young, Aug 21, 2015.

  1. Chuck Young

    Joined:
    Jun 25, 2015
    Messages:
    621
    Likes Received:
    192
    So from time to time the thing says there is a new upgrade and it is needed.

    So what is up with that?
     
  2. xave

    Joined:
    Aug 7, 2015
    Messages:
    298
    Likes Received:
    136
    Forgive me but I'm going to ask the obvious. Are you currently using the latest firmware for the Phantom and the controller? As well as the latest App?
     
  3. tvleaker

    Joined:
    Aug 3, 2014
    Messages:
    51
    Likes Received:
    0
    I get the same thing.."Red triangle "aircraft update required" of course I had the latest firmware. This is my second P3 pro and I did the update last week. After getting the update notice on my app I did the update again. And got a " the version is the same as the precious update" I have been just closing the warning and flying with no problem. but I too am curious WHY
     
  4. Chuck Young

    Joined:
    Jun 25, 2015
    Messages:
    621
    Likes Received:
    192
    I would guess probably NO, I a using the firmware that works for me. I am good with that.
     
  5. BenDronePilot

    Joined:
    Dec 7, 2013
    Messages:
    1,204
    Likes Received:
    131
    It did the same for me after updating both my Phantom and RC to the latest firmware as well as the latest DJI Go app. It hasn't done this tho after the last few power cycles since I redid IMU and Gimbal Calibrations. It could be a a random bug in the firmware or the go app.