Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Upgrade Critical Error, all the red leds solid

Discussion in 'Pro/Adv Discussion' started by Johnnygrinder, Sep 7, 2015.

  1. Johnnygrinder

    Joined:
    Jun 26, 2015
    Messages:
    7
    Likes Received:
    1
    First of all i've upgraded my own P3A and everything went ok

    This afternoon my friend has asked me to help him to upgrade his P3A and after 23 min of all the d-d-d-d the leds on the phantom turned all solid red... and nothing, no noise, no red/green light on the gimbal.

    We shut down the P3A and tried again but the upgrade won't start, it's like it doesn't read the file from the card.

    Once again we have tried different cards and changed the battery. Nothing

    The worst of all we connect the phantom with the RC and the android phone, no signal from camera. The version of firmware is 1.3.20. We can fly the phantom but the gimball or camera doesn't respond :-(
    .
     
  2. thestone11

    Joined:
    Mar 3, 2015
    Messages:
    296
    Likes Received:
    32
    Location:
    Alberta Canada
    Did you check the log on the sd card? Before you try again, make sure to delete the log on the se card!
     
  3. Johnnygrinder

    Joined:
    Jun 26, 2015
    Messages:
    7
    Likes Received:
    1
    There was no log! I have tried over and over again. No response from Camera or gimbal
     
  4. Fplvert

    Joined:
    May 28, 2014
    Messages:
    1,559
    Likes Received:
    708
    Location:
    Southern Idaho USA
    Hi Johnny,
    When I updated to 1.3.2, I noticed the bird appeared to stop loading for maybe 5 minutes. The camera hung down and nothing seemed to be happening. Then, it started the chirp and flashes again. It took less than 10 minutes and the D...DD chirp started indicating the update was complete.

    I'm guessing you stopped the update before it was completed. This could mean a return trip to DJI.:eek:

    You might be able to update though the GO App., though. You might give that a try!
     
  5. Chuck Young

    Joined:
    Jun 25, 2015
    Messages:
    621
    Likes Received:
    192
    Did you pull the battery out? Maybe start from scratch, unzip the file onto a fresh formatted SD.
     
    Fplvert likes this.
  6. flyNfrank

    Joined:
    Feb 1, 2014
    Messages:
    4,227
    Likes Received:
    914
    Location:
    Indy, USA
    What did the included .txt file say near the bottom? aborted? not complete?

    Always run the update until you hear the D.D's go from 4 down to 3. When you hear 3 you then power down, other wise it is still updating.
     
  7. Mad_angler1

    Joined:
    May 18, 2015
    Messages:
    101
    Likes Received:
    46
    Location:
    Wales UK
    Leave it sit with the battery out for 20m, then turn it one with out the SD card in, if you get a constant beep just leave it until it stops, could take 10 minutes, then turn off and try the update again.

    Sounds like you cut it off before it was done.
     
  8. Phantom751874

    Joined:
    Mar 13, 2015
    Messages:
    995
    Likes Received:
    269
    Yes, when I went to 1.3.2 the same happened to me. I let it sit like that (all red gimbal limp) for 5-10 minutes and it finally picked up and finished. Just be patient in the future, after you get this fixed, when you upgrade firmware. Always watch the gimbal light to tell if the upgrade has completed.
     
  9. Johnnygrinder

    Joined:
    Jun 26, 2015
    Messages:
    7
    Likes Received:
    1
    Update:

    I give up yesterday.

    I started today by low formatting the card (it took so long) putt a fresh and charged battery and finally all ok.

    Thank god all works. Upgrade OK
     
    Oso likes this.