Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3 Firmware Updated was almost catastrofical

Discussion in 'Firmware' started by Jacques Dompierre, Oct 10, 2016.

  1. Jacques Dompierre

    Joined:
    Oct 10, 2016
    Messages:
    6
    Likes Received:
    0
    Good day to all of you and thanks for accepting me in this forum.

    I went to fly this afternoon and after a regular check up ( read pre-flight ) I started to elevate the bird. After two minutes of flight, the bird started a descent by itself, tried to prevent it from doing this and land it to a safe place but no chance, I broke a prop on an hydro wire and down the drone went.

    Fortunately, only the prop was damaged. When I repowered everything, It said '' firmware update required '' even though I repulse the update until proven safe and sound.

    It must have been done through the IPad Dji Go application.

    Now I have an Issue.

    I can't connect to the burd through the remote. I have no battery level and no images. I installed the version 1.9 on the SD card ( formatted previously ) and inserted the Sd into the gimball but after four minutes, the bird stops flashing red-green for a solid red, ( the wait time was more than 20minutes )

    I've done that more than four times without success. Did I tell you that I HATE UPDATES .......Now I am telling you.

    Tried to roll back to 1.80 and I get the same reaction from the bird except that the text file says (( ABort same version on SD card as the bird )) update not completed.

    I am soooo frustrated, I will make this guy NEVER update again..I swear.
     
  2. Neon Euc

    Joined:
    Aug 15, 2016
    Messages:
    839
    Likes Received:
    206
    Thinking outside the box here but. Try connecting your controller with the phantom first. Once that's done try the update. Keep me updated and we will figure this out

    Sent from my Power using PhantomPilots mobile app
     
    Jacques Dompierre likes this.
  3. Jacques Dompierre

    Joined:
    Oct 10, 2016
    Messages:
    6
    Likes Received:
    0
    Hi and thanks for the reply. Since the incident, As I said, I tried to update the Bird with the remote powered on or Off and it does not change anything. I tried to pair the remote with the bird and It said '' success '' for the pairing.
    I hear from the gimball, weird noises, It is like '' dull '' and there is no counter-reactions as before when you try to move the camera/gimball assembly. More so, the gimball '' joints '' where the coils are located gets a little warm while the noise is coming from. The Up/down has some restrictions when you try to move it manually, left/right rotation does the same BUT the horizontal maintain has NO restrictions, like it lost nervous connections, and when you move it away from horizontal, you hear some noise ( like a gringing noise, ) from the gimball.

    When I plug the PC to the gimball with the proper cable, I can't see the SD card as before. **** update ....
     
    #3 Jacques Dompierre, Oct 10, 2016
    Last edited: Oct 10, 2016
  4. Jacques Dompierre

    Joined:
    Oct 10, 2016
    Messages:
    6
    Likes Received:
    0