Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

update to 1.3

Discussion in 'Pro/Adv Discussion' started by Pfgking, Jan 1, 2016.

  1. Pfgking

    Joined:
    Jun 26, 2015
    Messages:
    7
    Likes Received:
    0
    Hey guys,

    When I go to fly my drone, it says an update is required and i have to update to 1.3 to do in app updating (???)

    Does that mean i should update to 1.3 because i have older firmware?

    Thanks
     
  2. Reed L

    Joined:
    Sep 13, 2015
    Messages:
    1,265
    Likes Received:
    390
    Location:
    Alta, Ca.
    1.3 is the update where they changed the RC update over to being done live through the go app. Being that it's automatic and we're on 1.6.0 now, I think it will bypass the 1.3 and move on up to the current but I'm not positive. Updating is your choice, if you stay where you are it will flash the "needs update" for a few seconds and then it will go to "Safe to Fly"and you can take off.
     
  3. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,925
    Likes Received:
    5,574
    Location:
    US
    If you're using a version older than 1.3, you must install 1.3 before installing 1.6. If needed, you can find detailed firmware installation instructions here.
     
    bodine likes this.
  4. Pfgking

    Joined:
    Jun 26, 2015
    Messages:
    7
    Likes Received:
    0
    So should i update to 1.3 before 1.6?
     
  5. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,925
    Likes Received:
    5,574
    Location:
    US