Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Update problem

Discussion in 'Pro/Adv Discussion' started by KevinfromUK, Dec 18, 2015.

  1. KevinfromUK

    Joined:
    Apr 27, 2015
    Messages:
    27
    Likes Received:
    2
    I wonder if anyone can advise me on this?

    Today I tried to switch on my phantom 3 indoors just to test that the latest update had worked. when I switched on my tablet I got a message saying that the latest osmo firmware been released which of course has nothing to do with the Phantom. An audio announcement also said "please complete the aircraft status before taking off".

    When I got into camera view it did my firmware was up to date, but the copter controls would not operate. Also, it said that image transmission was poor, but that is strange, as the controller was only five feet away from the copter. I also noticed that there was a question mark against the compass calibration control.

    I have had this machine for three months now and have only flown it once as every time I try to use it I come up against a new problem
     
Loading...
Similar Threads - Update problem Forum Date
[RESOLVED] P4P firmware update causes no signal and other problems Phantom 4 Pro Help Yesterday at 5:28 PM
Problems after latest update Phantom 4 Pro Help Friday at 12:13 PM
V01.04.0602 Update for Those of You That Had Problems Phantom 4 Pro Discussion Wednesday at 3:15 PM
Another Update Problem Phantom 4 Pro Discussion Jun 14, 2017
Firmware update problem-help! Standard/4k Discussion May 21, 2017