Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

UPDATE: Help with Phantom Upgrade

Discussion in 'General Discussion' started by bushmg, Dec 25, 2013.

  1. bushmg

    Joined:
    Dec 25, 2013
    Messages:
    2
    Likes Received:
    0
    OK, I got a new Phantom for Christmas, put it all together and it flies great. So I want to enable IOC, right? I download the DJI Driver and NAZAM_2.20 installer and hook everything up. The software won't let me go to the other screens and it says

    "DJI NAZA-M Firmware 4.02 has been released. Please upgrade the NAZA-M Firmware to v4.02 using the Assistant Software v2.20. Important: 1. Make sure to reconfigure all parameters and recalibrate the transmitter in the Assistant Software after upgrading the firmware. 2. For the PHANTOM users, please download the Phantom Default Configuration Parameters...and upload them to the Main Controller in the Assistant Software, then reconfigure all parameters and recalibrate the transmitter."

    So I upgrade the firmware and immediately I get an ERROR [27] "GPS not calibrated, or magnetic field interference. Please calibrate GPS again in good condition."

    I download the default parameters. The Phantom just gives a rapid blinking (I think amber) light and it doesn't appear that the transmitter is connecting anymore. I try the Transmitter Calibration process in the Advanced Manual, but I don't get the single beep and nothing changes. I have checked the IMU and it is OK. The compass values are X:210 Y:184 Z:322 Mod:424.

    At the bottom of the screen it shows Mode: failsafe and MC OUTPUT: off

    Help, Please!

    Mike Bush
    Fort Worth, TX

    OK, after much searching I discovered that the V1.1 Phantom uses the D-Bus receiver type, not the PPM. Once that was sorted out, everything was fine.

    MODS: I apologize, this should have been in the HELP section.
     
  2. JTheed

    Joined:
    Dec 13, 2013
    Messages:
    87
    Likes Received:
    0
    Location:
    Southeast Florida
    You would think that if they just released a new Phantom, it would have already have come with the latest firmware which was released back in October or update the firmware to recognize which model it was talking to and update the default configuration file to set it to DBUS instead of PPM. Sounds like a case of rushing a product to market.
     
  3. Phantom556

    Joined:
    Nov 25, 2013
    Messages:
    15
    Likes Received:
    0
    Did you calibrate your compass?
     
  4. Kamgopro

    Joined:
    Dec 25, 2013
    Messages:
    11
    Likes Received:
    0
    Can you explain "V1.1 Phantom uses the D-Bus receiver type, not the PPM. Once that was sorted out,"? my new toy is in the mail and I'm trying to educate myself in preparation of the upcoming update.
     
  5. JTheed

    Joined:
    Dec 13, 2013
    Messages:
    87
    Likes Received:
    0
    Location:
    Southeast Florida
    Kamgopro: Before the V1.1.1 version of the Phantom, the receiver was a PPM type. It is now a DBUS type and when you run the NAZA assistant software, perform the upgrade to the firmware, you should also import the Default Configuration file. Once this is loaded, you need to go into the section of the NAZA assistant, under Basic, RC and put the Receiver Type back to DBUS mode as the default setting is PPM.
     

    Attached Files:

    • dbus.png
      dbus.png
      File size:
      194.2 KB
      Views:
      268