Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Update from 1.5.30

Discussion in 'Pro/Adv Discussion' started by DJJI, Apr 22, 2016.

  1. DJJI

    Joined:
    Jul 10, 2015
    Messages:
    190
    Likes Received:
    16
    Hello, it`s been too long since I have flown this ship.
    Should I update my software to the newest version

    And if I should, which of them should i update to?
    • Phantom 3 Professional Firmware v1.8.80
      2016-04-07
      ZIP
    • Phantom 3 Professional Firmware v1.7.0060
      2016-03-15
      ZIP
    • Phantom 3 Professional Firmware v1.3.20
      2015-08-04

    I know have the version:
    Phantom 3 professional: 1.5.30
    Remote controller: 1.5.70


    Thank you in advance, best regards
     
  2. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,957
    Likes Received:
    1,944
    Location:
    San Francisco, CA
    You should definitely upgrade the P3P FW as 1.5.3 is not stable and 1.6 has better solution for batteries.

    If you are upgrading in anyway, you should upgrade to the latest. You should note that the latest FW on RC and AC work in hand to hand, that means you need to have both upgraded as DJI has implemented encryption in signal transmission for security. That means you should have RC updated to 1.6.0 and AC to 1.8.80. Needless to say, you should upgrade App also to the latest.

    Are you familiar with the upgrade process? If not, follow detailed steps provided by msinger.

    P3 Firmware - HOW TO: Install Phantom 3 firmware
     
    meissner58 likes this.
  3. 2k3sgm

    Joined:
    Apr 27, 2015
    Messages:
    117
    Likes Received:
    34
    I did the jump from 1.5 to 1.8 yesterday. Mine would NOT let me go right from 1.5 to 1.8. I had to load 1.7 first then 1.8.
     
  4. DJJI

    Joined:
    Jul 10, 2015
    Messages:
    190
    Likes Received:
    16
    Thanks, I know how to update. I just hear some bad things about theese updates here and there so I just had to make sure that I didn`t do anything super stupid.

    Does anyone know if litchi is coming with touch object and fly after it with the phantom 3 proffesional?

    Thanks alot, have a nice weekend!

    Fly safe!
     
  5. flyNfrank

    Joined:
    Feb 1, 2014
    Messages:
    4,301
    Likes Received:
    942
    Location:
    Indy, USA
    I'm on 1.4.1 and stayin right there unless the moon turns green.
     
    CANEKiTA, alokbhargava and AL T like this.
  6. Jeriami

    Joined:
    Oct 9, 2015
    Messages:
    151
    Likes Received:
    28
    Sorry to but in, but once i upgrade batteries & craft & RC, should i remove the FW update or leave it there?
     
  7. AL T

    Joined:
    Apr 13, 2015
    Messages:
    117
    Likes Received:
    18
    Location:
    Henderson, NV
    Good to hear I'm not alone
     
  8. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,957
    Likes Received:
    1,944
    Location:
    San Francisco, CA
    If you follow installation procedures correctly, chances of failures are minimal.

    Litchi has Track feature for iOS. Select an object and it follows it.
     
  9. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,957
    Likes Received:
    1,944
    Location:
    San Francisco, CA
    I am waiting for the day when moon turns green, we will celebrate for Frank
     
  10. NimpoCub

    Joined:
    Jan 21, 2016
    Messages:
    128
    Likes Received:
    28
    Location:
    Nimpo Lake, BC
    make sure your batt's are updated, then remove it.
     
  11. robinb

    Joined:
    May 10, 2014
    Messages:
    3,000
    Likes Received:
    521
    As you know we had a green moon this side of pond and i went from 1.4.1 to 1.8 last week.
    No regrets so far.
    I fact I think 1.8 is better.
     
  12. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,957
    Likes Received:
    1,944
    Location:
    San Francisco, CA
    Very strange.
     
  13. Indiana_pyro

    Joined:
    Feb 11, 2017
    Messages:
    22
    Likes Received:
    6
    I just bought another pro and it has FW 1.5.30+ and RC has 1.6.0 For the seasoned FW guys- can I go straight to the latest or do I need to upgrade in steps ? Or is there any other advice to help me.
     
  14. Indiana_pyro

    Joined:
    Feb 11, 2017
    Messages:
    22
    Likes Received:
    6
    Or maybe go to 1.8 and stop ?
     
  15. Quest-So

    Joined:
    Jan 5, 2017
    Messages:
    71
    Likes Received:
    16
    My advice is go to AC v1.8.80 and stay there. See my FW configuration in the signature. I don't recall someone has complained about FW issues with v1.8.80. It's a true successful version.

    See my iPad iOS version, it's still v9.3.5. Apple is offering me since September 2016 to update to v10, but I'm still unconvinced I should do it (because the mini 2 functions flawlessly), even from the trouble maker v10.0.1 in the mean time the OS evolved 6 (six) consecutive versions up to v.10.2.1.

    The same applies with DJI's AC v1.10.90 it created so much frustration among a lot of P3P/P3A owners, that by no means I will update to it by my own choice.

    Waiting what the future brings :)
     
  16. Indiana_pyro

    Joined:
    Feb 11, 2017
    Messages:
    22
    Likes Received:
    6
    Thank you. That is what I have now done. After hearing some are trying to downgrade from the latest, I didn't see a reason to go there yet
     
  17. Quest-So

    Joined:
    Jan 5, 2017
    Messages:
    71
    Likes Received:
    16
    Yes, I forgot to mention this too, AC FW v1.10.90 not only that is reported to bring trouble, but it's designed in such a way that you cannot downgrade to a previous version that you know it ran well, say v1.9.60. A bit unfair...
     
  18. Indiana_pyro

    Joined:
    Feb 11, 2017
    Messages:
    22
    Likes Received:
    6
    Well the 1.8.80 seems to be working good, but why in the go app does it say 1.8.80+
     
  19. jakeV616

    Joined:
    Sunday
    Messages:
    2
    Likes Received:
    0
    Location:
    Memphis, TN
    What firmware update will enable the camera on the P3A to shoot in 2.7k and what is the recommended best one? Currently on 1.5.30. Thanks!
     
  20. Quest-So

    Joined:
    Jan 5, 2017
    Messages:
    71
    Likes Received:
    16
    Jake this is strange, you say your P3A with AC FW v1.5.30 is not filming in 2.7K ? What FW has your RC ?
     
    jakeV616 likes this.
Loading...