Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Ultrasound Error

Discussion in 'Pro/Adv Discussion' started by Gumby, Jan 31, 2016.

  1. Gumby

    Joined:
    Nov 26, 2015
    Messages:
    19
    Likes Received:
    4
    I have a couple P3 Pros. On one of my birds, I have been getting an "Ultrasound Error - Land as soon as possible." This error usually occurs about 5 - 8 minutes into a flight. There are no other problems. Flying with latest software. Using iPad mini 3. I have done IMU calibration and gimbal calibration to no avail. I do a compass calibration before each flight.

    When I land on autopilot, the bird comes down pretty fast. When ultrasound actually works, it slows down a few feet before touchdown.

    Any thoughts regarding cause and solutions? Thanks!

    -gumby
     
  2. Meta4

    Meta4 Moderator
    Staff Member

    Joined:
    Jan 8, 2014
    Messages:
    7,763
    Likes Received:
    3,470
    I haven't seen that since a very early firmware version - it was correct in subsequent versions.
    What firmware version are you running?

    Disable VPS in the app and you won't see that error again.
     
  3. Gumby

    Joined:
    Nov 26, 2015
    Messages:
    19
    Likes Received:
    4
    Hi Meta4. If I disable the VPS, I assume the error will go away. However, won't the ultrasound function also be turned off? I kind of like the soft auto landings. (I'm running the latest firmware.)
     
  4. Meta4

    Meta4 Moderator
    Staff Member

    Joined:
    Jan 8, 2014
    Messages:
    7,763
    Likes Received:
    3,470
    Sorry ... I've only seen that back in the early days of the P3 and never heard of it since.
    Disabling the VPS would switch it off completely so you wouldn't get the error but I don't know what other complications there might be if you run with it on.