Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Turning IOC on

Discussion in 'Pro/Adv Discussion' started by Ron, Jun 8, 2015.

  1. Ron

    Ron

    Joined:
    Apr 29, 2015
    Messages:
    29
    Likes Received:
    5
    I've received my Phantom 3 Advanced and can't believe how good it is. I've only had a couple of short flights so far, but I find the video stabilisation amazing and am really pleased with the quality.
    I've been reading this forum while waiting for it to arrive and appreciate all of the help and advice given on it.
    I've had none of the problems I read about, but the only thing that puzzles me is that I can't turn the IOC on in the advanced settings. The slider just keeps sliding back to the off position. Any ideas would be appreciated.
     
  2. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    You need the phantom turned on and connected, first enable the IOC modes then watch what happens in the app when you toggle the lever on left side of controller.
    This is similar to previous phantom assistant in that it gives you visual confirmation the switch is working.
    Be ready to switch back and give yourself plenty of space at first when trying - it can be a bit disorientating.
     
  3. Ron

    Ron

    Joined:
    Apr 29, 2015
    Messages:
    29
    Likes Received:
    5
    Thanks for the reply, but my problem is that I can't enable IOC, it keeps sliding back to off.
    The phantom is connected and everything else works well.
     
  4. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    There's two switches, you enable the multimode or whatever they call it, then the switch below changes on its own when you move the controller lever.
     
  5. Ron

    Ron

    Joined:
    Apr 29, 2015
    Messages:
    29
    Likes Received:
    5
    Thanks again. I've enabled the multimode but the IOC just keeps sliding back to off. The first time I tried it it worked okay, but now I can't make it stay on.
     
  6. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    But what happens when you move the lever on the controller?
     
    Coldfire likes this.
  7. Ron

    Ron

    Joined:
    Apr 29, 2015
    Messages:
    29
    Likes Received:
    5
    I will try that and see. The battery is charging at the moment but I will check then.
    I thought I had to enable it first, but I will check this out.
    Thank you for your help
     
  8. sdharris

    Joined:
    May 9, 2013
    Messages:
    450
    Likes Received:
    151
    Location:
    South West, England
    I had a similar problem, the IOC switch in the app just slides straight back to off. I got it working by enabling multi flight mode and the IOC switch. It certainly wasn't as straight forward as it appeared in the manuals and from other peoples advice.

    Also make sure you are not in beginner mode.
     
  9. snowghost

    Joined:
    Feb 13, 2015
    Messages:
    1,056
    Likes Received:
    212
    Location:
    SoCal, USA
    So at the moment only Course Lock works?
     
    mmee1992 likes this.
  10. mmee1992

    Joined:
    Mar 14, 2015
    Messages:
    340
    Likes Received:
    139
    I believe so.
     
  11. Recce2

    Joined:
    Dec 4, 2013
    Messages:
    103
    Likes Received:
    31
    Location:
    Duluth, MN
    Correct:
    1. Turn on Multiple Flight Mode (option just above IOC)
    2. Switch the Flight Mode Switch on the Remote Controller from P to F
    You will get a pop-up window giving you an option to cancel.
    You are now in Course Lock
    3. Turn off Couse Lock by moving Remote Controller Swith back to P.
    No other flight Modes are available yet.
     
    snowghost likes this.
  12. deepeshdotcom

    Joined:
    Aug 20, 2014
    Messages:
    43
    Likes Received:
    8
    Location:
    Sydney, Australia
    I have the latest firmware on the qopter, remote and battery. I cant turn on IOC on the app even multi flight mode is on.When I flip the switch to F, I can get to course lock and home lock but it doesnt work because i cant turn on the IOC . Anybody had same problem? How did you solve it?
     
  13. invinciblevin

    Joined:
    Jul 30, 2015
    Messages:
    35
    Likes Received:
    5
    Since latest firmware update IOC slider isn't used. Enable multi flight mode in app. When craft is in the air switch PAF switch to F.
    Choose which mode you require. Course lock, Home lock ,POI, Waypoints etc. To disengage switch back to P. If you switch to F. Look at app screen. It will tell you to switch it in flight.
     
    deepeshdotcom likes this.
  14. deepeshdotcom

    Joined:
    Aug 20, 2014
    Messages:
    43
    Likes Received:
    8
    Location:
    Sydney, Australia
    I did the same but CL didn't work