Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Troubleshooting Fatshark w/Phantom 2

Discussion in 'FPV (First Person View)' started by video_nut, Aug 25, 2014.

  1. video_nut

    Joined:
    Aug 19, 2014
    Messages:
    6
    Likes Received:
    0
    I have the phantom 2 and the fatshark

    I bought the plug and play cable

    I have plugged the cable into the cam (phantom 2)

    the two connectors into the fatshark

    the gopro is connected

    when I power on the phantom the fatshark powers on but i get no video in the goggles....just static

    anyone have any ideas?
     
  2. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    Which plug n play cable do you have exactly?

    Are you using a gimbal, and if so, which one?
     
  3. video_nut

    Joined:
    Aug 19, 2014
    Messages:
    6
    Likes Received:
    0
    Plug and Play Cable: DJI Phantom 2 to iOSD Mini and Fat Shark/ImmersionRC Transmitter

    I don't have the iosd.....was told when i bought that it would work without it (i plan on purchasing the iosd later)

    I have the Zenmuse H3-3d gimbal
     
  4. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    If it's the one with the port in the middle for the iOSD mini, it won't pass video without that connected...the video has to pass through the iOSD mini so right now there's no video chain from the Phantom to your transmitter.

    This is the one you need when there's no iOSD connected: http://www.firstpersonview.com/cables/d ... tter-cable

    Your other option in the meantime would be to bridge both of the black and both of the yellow pins on that plug (the one that connects to the iOSD mini).
     
  5. video_nut

    Joined:
    Aug 19, 2014
    Messages:
    6
    Likes Received:
    0
    that's what i did

    it seems that iosd does have to be connected otherwise the connection between the video is broken. I cut the iosd connector out and spliced the black and yellow wire together and now I have video.....down the road when i have another 70 dollars laying around I will purchase the iosd and then reconnect the connector.