Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Trouble with upgrading to 1.08

Discussion in 'Phantom 2 Discussion' started by pos, Mar 23, 2014.

  1. pos

    pos

    Joined:
    Mar 23, 2014
    Messages:
    2
    Likes Received:
    0
    Hi guys,

    I tried updating my Phantom 2 last night, but something went wrong. While connected to my mac, the application said "Please wait, updating", and the Phantom made some beeping noises. After a long time (more than 30 minutes), I decided to try again, and disconnected the Phantom (nothing was responding anyway). Now it just keeps on making these beeping noises whenever I power it on, and the application says it's firmware 1.08, so I can't update anything. The Phantom won't connect to the remote either, so it's basically a brick. Please note that the beeping noises it makes, are not like the usual ones - it's more like a rhythm that changes over time (same noise it was making while it updated).

    I really hope someone can help me out with this, my Phantom is basically useless now.
     
  2. goldfishrock

    Joined:
    Jan 7, 2014
    Messages:
    427
    Likes Received:
    0
    Location:
    Devon, UK
    That's not good :-( You should be able to reapply the 1.08 firmware update even though it says 'Latest Version'. Just click on it and it should allow you to retry the flash. If that fails you could try downgrading your firmware... you may need to contact DJI (good luck with that!) to do this though.
     
  3. pos

    pos

    Joined:
    Mar 23, 2014
    Messages:
    2
    Likes Received:
    0
    Just an update on this: nothing I did seemed to work, so I gave up and tried contacting DJI. That wasn't so easy, but then I noticed that v2 of the Phantom Software was released. I downloaded it and upgraded, and now the Phantom seems to be all good!
     
  4. Fink

    Joined:
    Feb 25, 2014
    Messages:
    195
    Likes Received:
    0
    Location:
    Orlando, FL
    Good to hear!

    Fink[​IMG]