Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional trouble updating to v1.4

Discussion in 'Phantom 3 Help' started by videopro, Sep 12, 2015.

  1. videopro

    Joined:
    May 6, 2015
    Messages:
    36
    Likes Received:
    0
    need help desperatly!! i recently upgraded my phantom 3 professional to v1.4, had no trouble with previously version. i think my v1.4 was successful, but i didn't realize i had to check camera status led, i checked text file and it read success. so i mistakenly downgraded to previous v1.3.2. the downgrade resulted in loud siren like continuous beeping. i formatting the sd card and reinstalled v1.4 making sure it was a bin file only. i had text file reading success, but the video feed on my mini pad 2 was distorted, the camera feed was unstable and would switch to video feed with the distortion, also file from sd card was distorted. so next i reset all on rc. i formatted sd card again downloaded v1.4 with bin file. twice i have tried to reinstall, each time 2 hours or more. camera led flashing red and green, camera tilted and no beeps from unit. SUGGESTIONS PLEASE
     
  2. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Try reformatting the SD card first. It need to be completely blank. Then copy the 1.4.1 bin file on the card and do the update.
     
  3. videopro

    Joined:
    May 6, 2015
    Messages:
    36
    Likes Received:
    0
    thanks, i have formatted the sd card a number of times with my disc utility on macbook pro. i have tried 2 other sd cars, reformatting on macbook pro and each time downloading a new download of v 1.4.
     
  4. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    I use windows, right click, Quick format--format fatX -- make sure the format file system is correct-- there are file system formats that the Phantom wont read.
     
  5. videopro

    Joined:
    May 6, 2015
    Messages:
    36
    Likes Received:
    0
    Hi, formatted with windows as directed, downloaded v1.4. Did upgrade. Result: update ok. However no video feed, can't adjust camera setting, also No Signal banner. Any other suggestions? Please. All worked fine before upgrade
     
  6. Mordor

    Joined:
    Jul 27, 2015
    Messages:
    639
    Likes Received:
    114
    Seems now that the problem is your tablet/Phone...

    Can you use other one? IS it the last version?