Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Trouble Binding Futaba T14SG with P2

Discussion in 'Phantom 2 Help' started by rbhaigh@comcast.net, Aug 28, 2014.

  1. rbhaigh@comcast.net

    Joined:
    Aug 28, 2014
    Messages:
    2
    Likes Received:
    0
    I have been unsuccessful in getting my Futaba T14sg To FULLY communicate with my Phanthom 2. I also have a zenmuse H3 3D on board and a DJI Lightbridge. I believe I have the latest assistants and software upgrades done. I can see throttle, elevator, aileron, etc movement thru the assistant, but I cannot even power up the P2. Fairly certain I have the R7008 set to the right setting for S-Bus, but just coming up short otherwise.... Ideas or things to check?

    Thanks in advance

    Robert

    PS- I started with a great tutorial by Brandon Ballard which was really helpful but still no joy.
     
  2. 750r

    Joined:
    Nov 27, 2013
    Messages:
    1,226
    Likes Received:
    420
    Location:
    Pa, USA
  3. PhantomPhreak

    Joined:
    Apr 8, 2014
    Messages:
    312
    Likes Received:
    20
    Location:
    The OC in CA
    I didn't install the Futaba receiver in mine but after binding with my 14SG it would not start. Messed with it for awhile then thought to try putting the sticks in the upper corners, fired it up. The only problem when I went to power off I pulled the left stick down and almost flew it off my desk. In RC assistant I had to set the throttle and elevator to "Reverse".
    Edit: Something else I thought of. If you are using the V5 profile referenced in previous post make sure the triple rate is off. Since it limits the control, the P2 doesn't see the sticks at full in the corners and it will not start. Make sure to do a calibrate and sticks are going to 1000 at the ends.
     
  4. rbhaigh@comcast.net

    Joined:
    Aug 28, 2014
    Messages:
    2
    Likes Received:
    0
    Thanks Phantom Phreak

    But sadly, still no go. Did the sticks calibration, followed by the P2 assistant calibration without luck. I get movement on all the sticks, but can't fire it up. I do see that the P2 Assistant is showing me as being in D-Bus, but I have properly set the R7008SB multiple times to S Bus- ??? Do I need to be on a specific channel? I seem to be unable to change the channel in the SBus servo settings. I can change it but it defaults back to Ch1 next time in the menu