Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Transmitter stuck in mode 2

Discussion in 'General Discussion' started by rlambertiv, Jul 25, 2014.

  1. rlambertiv

    Joined:
    Jul 25, 2014
    Messages:
    4
    Likes Received:
    0
    I calibrated my transmitter using RC Assistant. I prefer mode 1, and when I move the sticks while connected to RC Assistant, the program indicates the proper functions associated with the sticks when I move them. however, when I go to fly, the function of the sticks are reversed (as with mode 2). I'm stuck in mode 2 and want to be in mode 1. I've recalibrated, cycled power,etc., etc.
    Any ideas?
     
  2. QYV

    QYV

    Joined:
    Apr 1, 2014
    Messages:
    1,814
    Likes Received:
    7
    Location:
    NYC
    The difference between Mode 2 (the default) and Mode 1 is simply which stick is throttle and which is lateral.

    Mode 1, the lateral is on the left stick and the right stick is throttle/rotate. basically the opposite of every Xbox game :)

    You indeed switch between them in the RC assistant software in the "stick mode" section it's either one button or the other. Are you saying that no matter which mode you choose the sticks don't change function?
     
  3. rlambertiv

    Joined:
    Jul 25, 2014
    Messages:
    4
    Likes Received:
    0
    Correct. I have changed modes in RC assistant and done the calibration, etc. but the stick functions remain the same after I disconnect. While connected, however, the sticks are like I want them according to the sliders on my computer screen. But, if I disconnect and go outside to fly, the throttle/rotate are on the opposite side. I'm very puzzled.......

    I am having a bigger problem though. The drone WILL NOT hover in place. It drifts left or right always. It is not being carried by the wind, but it seems to have a mind of its own. It is impossible to bring it straight down and land smoothly because it is always moving left or right as you descend. I have home location established and 10 satellites. It is also brand new. I have had a phantom 2 vision, and the vision plus is new. I have calibrated compass, controller and drone. All software up to date. I think it is defective. Any ideas?