Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Tilt angle

Discussion in 'Phantom FC40 Discussion' started by Bob Dennis, Aug 11, 2015.

  1. Bob Dennis

    Joined:
    Jun 27, 2015
    Messages:
    26
    Likes Received:
    3
    Location:
    Plymouth
    OK chaps I have fitted a Walkera G-2D gimbal to my FC40 in place of the original fixed camera mounting. I have wired the power to the two flying leads inside the Phantom and have added the extra wire for the remote pitch tilt control of the gimbal. I have fitted a genuine DJI tilt control to my transmitter and checked it in Naza and calibrated it. I was very pleased as it all worked first time after a lot of juggling with figures in the naza gimble set up. I have set it so that the gimbal looks straight ahead and ninety degrees straight down and varying between the two with the tilt leaver. My problem is that although the gimbal moves over the complete range it only responds to the second half of tilt leaver moment. I have been altering the figures in the naza gimbal settings Max Centre Min to no avail. Anyone out there have any ideals, sorry its a long question but wanted to get it right.
     
  2. mikey

    Joined:
    Jun 17, 2014
    Messages:
    146
    Likes Received:
    6
    I have no answer. Although I have ordered a G2D gimbal, and tilt lever... just waiting for them to arrive... so I'll watch closely to answers in this thread. I've done all the research and youtube watching for gimbal install, and i feel comfortable in the knowledge I've gathered... haven't done much research about the tilt lever yet (or settings)... so... that's my next week's worth of reading/watching.
     
  3. IflyinWY

    Joined:
    Sep 12, 2014
    Messages:
    3,470
    Likes Received:
    939
    Location:
    Where the deer and the antelope play
    Sounds like your Max (or min, depending on whether it's reversed or not) is set to the mid position of the lever.
     
  4. photoman63

    Joined:
    Oct 2, 2015
    Messages:
    12
    Likes Received:
    0
    I have the walkera 3D would love to know your steps to hook it all up .
     
  5. Bob Dennis

    Joined:
    Jun 27, 2015
    Messages:
    26
    Likes Received:
    3
    Location:
    Plymouth
    Hi first I read the instructions then watched a few videos on youtube about it. It was all quite easy and straight forward really. I had to drill a few holes in the mounting plate to mount it aft a bit more so my battery door would open. I then removed the top of the Phantom and found the spare power lead inside. To this I connected the power for the gimbal inside the body after first inserting it through the provided hole above the leg. As my gimbal is a 2g I connected one wire to the fight controller I think if was f1again passing the wire through the provided hole. Turned it all on and it worked, you have to go into Nazam and turn it on and make a few adjustments. The only other thing I did was to buy a set of leg extenders to give the camera / gimbal ground clearance
    Well worth it makes the videos so so steady, have fun.
     
  6. photoman63

    Joined:
    Oct 2, 2015
    Messages:
    12
    Likes Received:
    0
    Have you installed the pitch control on your tx yet?
     
  7. Bob Dennis

    Joined:
    Jun 27, 2015
    Messages:
    26
    Likes Received:
    3
    Location:
    Plymouth
    Yes did that first other wise the pitch would not work. Easy job 15 mins. there is also a how to do it on youtube.
     
  8. Bob Dennis

    Joined:
    Jun 27, 2015
    Messages:
    26
    Likes Received:
    3
    Location:
    Plymouth
    Just to let anyone who is interested all working now. It was just a matter of playing with the numbers in the gimbal set up in Nazam. Just for interest I ended up with Max 460, centre 250, min -30 all now is OK.
     
  9. photoman63

    Joined:
    Oct 2, 2015
    Messages:
    12
    Likes Received:
    0
    Thanks for the numbers. Hopefully I will be able to mount my 3D this evening.
     
  10. photoman63

    Joined:
    Oct 2, 2015
    Messages:
    12
    Likes Received:
    0
    Well, after the install. I was able to update the NAZA settings. However. I can't get out till 90 ° down. It seems I must choose numbers that is out of its max range ( 1000 to -1000) there id's an on screen tip that talks about chsnging the max limits. But it doesn't day how to change the max limits. Any idea?
     
  11. Bob Dennis

    Joined:
    Jun 27, 2015
    Messages:
    26
    Likes Received:
    3
    Location:
    Plymouth
    I used someone else's numbers of the net and had similar problems, its just a matter of playing with the numbers for your set up. It took me two hour sessions to crack it on mine. Once you work out what does what it all becomes clear.