Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Throttle Stick Problems Since Installing H3-2D

Discussion in 'Phantom 1 Help' started by PhantomFrey, Sep 8, 2013.

  1. PhantomFrey

    Joined:
    Sep 8, 2013
    Messages:
    4
    Likes Received:
    0
    I'm new around here and have been searching for a solution to my new problem with no luck. If you can provide any suggestions, I certainly appreciate it.

    I have installed the H3-2D gimbal with upgrade kit and the gimbal appears to function properly. However, since installation I have not been able to fly the Phantom, because my throttle stick does not function properly. I pull the two sticks in and back to start the rotors and then as I try to throttle up, the throttle stick is totally unresponsive until I pass 50% at which time the rotors kick up to 50% and seem to operate as expected beyond 50%. Drop the throttle stick below 50% and the rotors slow down to default startup speed.

    I have restored the default Phantom parameters downloaded from the DJI support page. I have tried calibrating through the Assistant software and also the transmitter calibration process to no avail.

    Here are a bunch of screenshots of my current settings for reference. Any help you can provide is appreciated. Thanks!
    http://goo.gl/cf7k3h

    --
    Frey
     
  2. bumper

    Joined:
    Aug 6, 2013
    Messages:
    94
    Likes Received:
    0
    I'm still running 3.14, but with a Futaba T8J, and that's the way my throttle behaves until takeoff . . . I thought that was normal. After takeoff, 50% throttle is hover and through the lower half of the throttle range the motors behave in a more linear fashion.

    That is, until my crash yesterday :cry: now it's pretty much screwed.

    bumper
     
  3. mroberts

    Joined:
    Apr 2, 2013
    Messages:
    162
    Likes Received:
    0
    I'm assuming you have an "older" Phantom, and this is the first time you've upgraded your firmware (as part of the gimbal install).

    From Firmware ?3.14? and beyond, the throttle behaviour in GPS mode changed. Rather than having a continuous response from 0-100%, 50% is "hover", regardless of actual required power.

    To take off, you bring the throttle up to / above 50%. Once you're flying, setting it at 50% should give you hover. No amount of reconfiguration will help - it's part of the firmware.

    ATTI mode still behaves as it used to, with a continuous throttle response. Try a ground run in ATTI mode, and you should see the behaviour you're used to (although you'll have to "fly" it all the way off the ground since you don't have the GPS assistance).

    If you're really worried, pull the gimbal and camera and give GPS mode a try to get used to the new behaviour. It does make life easier since you've got a constant hover throttle setting.
     
  4. PhantomFrey

    Joined:
    Sep 8, 2013
    Messages:
    4
    Likes Received:
    0
    You are 100% correct.

    Thank you! I just thought I was doing something wrong. A couple test flights without the gimbal/camera may be in order, that's a great idea! Cheers! :D
     
  5. mroberts

    Joined:
    Apr 2, 2013
    Messages:
    162
    Likes Received:
    0
    I think at least part of this is also explained in the release notes and updated manuals. While they don't TELL you they've done it, DJI does update the manuals periodically so it's worthwhile making sure you've read the latest versions.