Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Three constantly blinking red lights and constant beeping

Discussion in 'Phantom 2 Vision + Help' started by jrod1944, Oct 17, 2016.

  1. jrod1944

    Joined:
    Jun 7, 2014
    Messages:
    54
    Likes Received:
    5
    Location:
    Panama
    I recently had the biggest crash in 3 years of flying my Phantom 2 Vision Plus. The landing gear was ripped off. In addition to various cracks and scrapes, The compass cable had a break, and the camera took a big hit. I took the camera and gimbal apart and it seems to be working. I ordered a compass cable from Ebay and changed it.
    When I turned it on I get three bed blinking lights and a constant beep. Can someone please help.
     
  2. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,418
    Likes Received:
    568
    Location:
    Sydney Australia
    Plug into the PC and use the Phantom Assistant app.
    It should at least provide you the errors/codes.
     
    N017RW likes this.
  3. jrod1944

    Joined:
    Jun 7, 2014
    Messages:
    54
    Likes Received:
    5
    Location:
    Panama
    I am trying that but don't know where to look for the error message. I also noticed that the compass seems to get very hot.
     
  4. jrod1944

    Joined:
    Jun 7, 2014
    Messages:
    54
    Likes Received:
    5
    Location:
    Panama
    I had left the old compass on when I changed the cable. With all that heat I figured I would change the old one for the one that came with the cable. Now it makes an attempt to start and no more red lights. However, now I have only one light on and a less audible constant beep.
     
  5. jrod1944

    Joined:
    Jun 7, 2014
    Messages:
    54
    Likes Received:
    5
    Location:
    Panama
    When I start it now, three red lights come on and then they go off and one white or amber light stays on and the rest go out. The beep keeps on going.
     
  6. jrod1944

    Joined:
    Jun 7, 2014
    Messages:
    54
    Likes Received:
    5
    Location:
    Panama
    I had left the old compass in and only switched the cable. After all the heat on the compass, I replaced the old one with the one that came with the cable. Now it starts up, three red lights come on then two go out and only one stays on and has changed to a white light.
     
  7. crash1sttime

    Joined:
    Oct 31, 2014
    Messages:
    928
    Likes Received:
    74
    Location:
    Manchester UK
    Sounds like the Naza has took a hit and maybe damaged, and also possibly at least one of the ESC's may be damaged, its hard to diagnose over a forum, i suggest you find a local repair guy and ask his advice.
     
  8. jrod1944

    Joined:
    Jun 7, 2014
    Messages:
    54
    Likes Received:
    5
    Location:
    Panama
    Thank you for the reply. I will do that.
    Jrod
     
  9. jrod1944

    Joined:
    Jun 7, 2014
    Messages:
    54
    Likes Received:
    5
    Location:
    Panama
    Problem resolved. Changed out the esc where the light was gone.
     
  10. jrod1944

    Joined:
    Jun 7, 2014
    Messages:
    54
    Likes Received:
    5
    Location:
    Panama