Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Tech Help: Turning It On.

Discussion in 'General Discussion' started by fuzzynormal, Oct 19, 2014.

  1. fuzzynormal

    Joined:
    Sep 27, 2014
    Messages:
    6
    Likes Received:
    0
    Not sure why all of a sudden I'm having this problem. I know that I'm kinda an idiot... so am I making a mistake or is it malfunctioning?

    Here's a video showing the issue:

    http://www.path88files.com/TEMP/IMG_0064.MOV

    Thanks in advance for any advice.
     
  2. Fplvert

    Joined:
    May 28, 2014
    Messages:
    1,559
    Likes Received:
    708
    Location:
    Southern Idaho USA
    :oops: push battery button once, then push again and hold it till bird chirps. You almost had it. Read the manual. :D
     
  3. fuzzynormal

    Joined:
    Sep 27, 2014
    Messages:
    6
    Likes Received:
    0
    Or re-read it. (again) My button pushing technique is too slow apparently. Oh well, I'm used to being an idiot. One more day doing so is nothing new.
     
  4. CYeutter

    Joined:
    Aug 6, 2014
    Messages:
    49
    Likes Received:
    10
    I had the same issue when I first got my P2V+. My timing between the two pushes apparently wasn't good plus, in an attempt to be gentile, I drastically underestimated the amount of pressure I needed to apply to the button. Actually contacted DJI tech support. I thought something was wrong with my copter. In retrospect it seems silly.
     
  5. Happyflyer

    Joined:
    May 5, 2014
    Messages:
    1,805
    Likes Received:
    98
    Location:
    Cold, Cold, Michigan
    Don't beat yourself up too much. Had same problem at one time and I read the manual and watched videos until I was sick of looking and reading. It just has to do with timing.