Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

T-motor problem

Discussion in 'Phantom 2 Vision + Discussion' started by Darren2264, Oct 23, 2015.

  1. Darren2264

    Joined:
    Apr 8, 2015
    Messages:
    3
    Likes Received:
    0
    I installed new tmotors in my phantom and one spins slower than the others and gets very hot. Any ideas what it could be. I don't know the tipacle symptoms of a bad motor or speed controller
     
  2. N017RW

    Joined:
    May 2, 2014
    Messages:
    6,244
    Likes Received:
    1,614
    Location:
    Palm Beach Co.- FL
    There's not much to go wrong in a motor unless it's been damaged/crashed.
    The bearings are the only moving parts.

    The quickest way to tell is to move the motor to another ESC.

    Then you'll know which it is.
     
  3. RoyVa

    Joined:
    Apr 10, 2015
    Messages:
    2,246
    Likes Received:
    449
    Location:
    Virginia
    Verify the motor and ESC are matched.
     
  4. Mark The Droner

    Joined:
    Aug 26, 2015
    Messages:
    3,983
    Likes Received:
    1,162
    Location:
    Brookeville, MD, USA
    See this video of a T motor replacement.



    In the vid, Ben talks about how the company mis labeled a motor on his, and also he heard of them mis-labeling a motor on another video he saw. In addition, after installation, one of his motors wasn't running right and he had to send it back.

    After seeing this vid, I've concluded that the T motors suck. If I ever replace my motors, I'll replace them with something else.