Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Switch S2 not functioning ?

Discussion in 'Phantom 2 Vision Discussion' started by ProfessorStein, Jun 21, 2014.

  1. ProfessorStein

    Joined:
    Jun 20, 2014
    Messages:
    1,136
    Likes Received:
    3
    Location:
    Portland, OR
    I used the RC Assistant and Vision Assistant to upgrade the firmware for both the controller and the Vision, and also changed the Vision to NAZA-M mode.
    But my Switch S2 still doesn't appear to function correctly. I can see the switch changing the settings in the Assistant software's "Channel Monitor" sliders on the View tab, so it's apparent that the channel is bound, transmitting and receiving just fine. But the IOC status under "Advanced" on that same tab does not update like I would expect it should (just always reads "off"... I would expect it to update to indicate Home Lock and Course Lock)... but I figured that might just be because it was indoors while I was doing my updates, and maybe it was smart enough to not turn on IOC if it didn't have a true GPS lock.

    But then I took it to my outdoor flying spot, set it out, and tried to switch S2 to Home Lock... nothing... it still operated as if IOC was off (rotated my yaw, and pushed forward on the pitch... and it went off in the direction it was facing instead of away from me). Same with the middle position.

    So... first, should the Assistant software be updating it's IOC status as I flip S2 while the platform is hooked up to my computer (indoors)?

    Second... what could be the causes of the switch not responding... especially when I see that the channel is receiving (within the Assistant)? It just seems as though the Vision has simply "forgotten" what it's supposed to do when it receives the signal.

    Anyone have any ideas?

    Thanks!
    -Carl
     
  2. BigTulsa

    Joined:
    May 29, 2014
    Messages:
    207
    Likes Received:
    1
    Location:
    Tulsa, OK
    Have you enabled IOC in the software for S2. Enabling Naza only enables S1 - IOC isn't enabled by default.
     
  3. ProfessorStein

    Joined:
    Jun 20, 2014
    Messages:
    1,136
    Likes Received:
    3
    Location:
    Portland, OR
    Hmmm... that most certainly could be it. I did not throw any configs that specifically mentioned IOC. Where/how does one enable IOC?
     
  4. BigTulsa

    Joined:
    May 29, 2014
    Messages:
    207
    Likes Received:
    1
    Location:
    Tulsa, OK
    Assistant software > Advanced > IOC > check "Intelligent Orientation Control"

    Turn your controller on and verify the sliders change when you change the S2 positions.