Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Surely somebody can figure out how to downgrade firmware to 1.3.50 or 1.4.60

Discussion in 'Standard/4k Discussion' started by bigdog21782, Aug 23, 2016.

  1. bigdog21782

    Joined:
    Jul 16, 2016
    Messages:
    19
    Likes Received:
    5
    Surely there has to be somebody on here that can figure out how to downgrade firmware to 1.3.50 or 1.4.60, come on guys it may fix everybody's connection problems
     
  2. eospro

    Joined:
    Dec 13, 2015
    Messages:
    33
    Likes Received:
    2
    Location:
    Central Coast, NSW, Australia
    Scroll to the bottom of the pages. Pick your firmware. Search and you will find how to install on your bird. Just remember when installed Go app will want you to update to latest version. Just ignore it. I only went back to 1.5.7 to get my range back.

    DJI Phantom Accessories & Tips - Phantom Help
     
    #2 eospro, Aug 23, 2016
    Last edited: Aug 23, 2016
  3. bigdog21782

    Joined:
    Jul 16, 2016
    Messages:
    19
    Likes Received:
    5
    Doing it that way still won't allow you to go back more than 1 firmware, so I updated to 1.6.80, now I can only go back to 1.5.70, but I want to go back to 1.3.50 or 1.4.60 and I was wondering if someone could look into it, there has to be a way.

    Sent from my Letv X500 using PhantomPilots mobile app
     
  4. eospro

    Joined:
    Dec 13, 2015
    Messages:
    33
    Likes Received:
    2
    Location:
    Central Coast, NSW, Australia
  5. bigdog21782

    Joined:
    Jul 16, 2016
    Messages:
    19
    Likes Received:
    5
    That method will still only take you back to 1.5.70, trying to go back any further results in the downgrade failing

    Sent from my Letv X500 using PhantomPilots mobile app
     
  6. guchino

    Joined:
    Jan 30, 2016
    Messages:
    31
    Likes Received:
    2
    I changed center board. (Part76) bought e-bay.
    Version 1.2.40
    Because I have many OEM batteries.
    Works well.