Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Advanced Suddenly the imu will not calibrate PLEASE HELP!!!!

Discussion in 'Phantom 3 Help' started by jabk0912, Jan 28, 2016.

  1. jabk0912

    Joined:
    Jan 26, 2016
    Messages:
    34
    Likes Received:
    1
    Recently purchased a used p3a.
    I flew it for a couple days with it saying that I needed to do a firmware update, so the other night i went through the process of doing so. I will say I did wreck it. Good enough to need to replace the propellers but flew great for the entire time Ive had it. Probably at least 10 or 15 flights after.

    I upgraded to the newest firmware (P3S_FW_V01.06.0040.bin) from a older firmware ( not 100% sure which one. It'd been 7 months or so since the previous owner had used it) At that time I wasnt aware that i was supposed to do an imu calibration at the same time.
    The next day I went out and flew it around for a while trying to get some footage of some cool looking fog that was up in the hills. I DID go up in to the fog a bit, but then decided it probably wasnt a good idea to try and get above it. I flew it around for another 10 mintues after that.

    After landing with no problem, probably 5 minutes later, I was dinking around and saw the button to check imu calibration, it said it needed to be recalibrated.
    I havent been able to fly it since.
    I attempted to calibrate and got the temperature warning. I assumed it was because it was too cold ( about 40 degrees).

    I have now tried it literally everywhere, and Im feeling defeated. There is so much information out there, but none of it seems to help in my situation. I also have tried to reinstall the same firmware, as well as the 1.5.30 ( i think is what it was)

    I get the temperature warning every.single.time. Sometimes it will act like its going to do it, taking about 20 minutes to get up to 40% at the most, but no matter what, i get the temperature out of range warning. HEEEELP!!

    Some Details -
    Error - The temperature is not within the acceptable range. Turn off the aircraft for five minutes, then restart, and try again.
    flashing red yellow and green.
    the bird itself makes a dd..dddd..dd..dd..dd..dd sound while doing this

    APP V 2.5.1
    AIRCRAFT V 1.6.40
    RC V 1.5.70

    Thank you for any insight
     
  2. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,410
    Likes Received:
    567
    Location:
    Sydney Australia
    Turn the phantom off and leave it in a cool place for an hour or so. The cooler the better. Now find a surface that is levelled with the horizon in all axis (use a spirit or bubble level). Now in order to do an accurate IMU calibration, try and do it the moment you turn on the phantom - DONT LET IT IDLE. Letting it sit idling will warm up the internals and therefore you will always get the TEMP warning.

    Let us know how you go...
     
  3. jabk0912

    Joined:
    Jan 26, 2016
    Messages:
    34
    Likes Received:
    1
    I've done that probably 30 times. ( not an exaggeration haha)

    Power off, remove battery. Heard people even talking about the refrigerated method, but I live in South Dakota, so the outside temp was cool enough. Had the remote and Dji App pulled up, with the calibrate button grayed out, and the second it goes where I can press it after powering it up, I do.
    Still nothing.
     
  4. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,410
    Likes Received:
    567
    Location:
    Sydney Australia
    You may have a locked gyro/accelerometer value. Can you post up pics of the Gyro and Acelerometer values in sensors tab. Check if there is one stuck on +/- 16.
     
  5. jabk0912

    Joined:
    Jan 26, 2016
    Messages:
    34
    Likes Received:
    1
    image.png image.png image.png Nope:/
     
    #5 jabk0912, Jan 28, 2016
    Last edited: Jan 28, 2016
  6. jabk0912

    Joined:
    Jan 26, 2016
    Messages:
    34
    Likes Received:
    1
    I've never been into a drone, but I'm mechanically inclined enough, I'd say..

    Should I open it up and look for anything in particular? Just seems so weird that it only happened when I had it "check imu"
     
  7. Crunch97

    Joined:
    Dec 31, 2015
    Messages:
    38
    Likes Received:
    3
    I had a stuck imu popped top released clips on black box in center, flip each side with my finger to reset gyro and reinstalled. work perfect.
     
  8. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,410
    Likes Received:
    567
    Location:
    Sydney Australia
  9. jabk0912

    Joined:
    Jan 26, 2016
    Messages:
    34
    Likes Received:
    1
    Oh really?
    Yeah, when I took those screen shots, it was probably about 30 degrees in my garage.
    Which values show the temperature problem?

    So with that being said, what can I do about that??


    Sent from my iPhone using PhantomPilots mobile app
     
    #9 jabk0912, Jan 30, 2016
    Last edited: Jan 30, 2016
  10. jabk0912

    Joined:
    Jan 26, 2016
    Messages:
    34
    Likes Received:
    1
    Also, just to update, I did make sure to reinstall firmware correctly, and no changes.
    Taking the top off just to double check the imu is not stuck, and it appears to be good as well. (All corners moving freely?)



    Sent from my iPhone using PhantomPilots mobile app