Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Strong Random Latency at close and far range. Is this the new app causing this?

Discussion in 'Pro/Adv Discussion' started by PhotoGuyAaron, Jul 17, 2015.

  1. PhotoGuyAaron

    Joined:
    May 27, 2015
    Messages:
    126
    Likes Received:
    35
    Today I flew one battery at a park that overlooks lake Washington. No signal issues at all. Then I switched to my second battery and got strong Latency and signal breaking up at the close range and father away. I trired auto channel and then manually tried them all got same result. Could this be linked the 1.2.0 app problems?
    Any pointers? I love this community and how people support each other!
     
  2. PhotoGuyAaron

    Joined:
    May 27, 2015
    Messages:
    126
    Likes Received:
    35
    I made sure the antennas were not crossed at all, spread all the way out and titled up a little. And I had my bluetooth and wifi off on my iPad 2 set to off,
     
  3. John Locke

    Joined:
    Jun 26, 2015
    Messages:
    2,981
    Likes Received:
    1,119
    Location:
    Yorba Linda, CA
    I haven't seen this with my P3P with 1.2.0 firmware, but I always manually choose the channel in the channel selector that has the least interference in the area. Also the data rate communication speed I use is 6, the factory default. If you happen to have changed the default setting from 6 for higher quality video monitoring, that will increase the data rate for better video but also increase the latency. The lower the data rate the lower the latency and the lower the video monitor quality.
     
    PhotoGuyAaron likes this.
  4. DiluxEdition

    Joined:
    Jun 30, 2015
    Messages:
    200
    Likes Received:
    50
    Yea, this is 100% the fault of 1.2.0. I never had any issues with 1.1.2. My ipad auto updated and now I have to deal with this stupid lag and signal problems which I noticed on the 1st flight with 1.2.0. No1 wants to admit that the problem is actually 1.2.0 and they tell you to do stupid things to try to fix it when they wont actually fix anything. Hopefully DJI does fix it though, but I have a bad feeling that it will only get worse and worse...
     
    PhotoGuyAaron likes this.
  5. CloudsNeverDie

    Joined:
    Jan 26, 2015
    Messages:
    227
    Likes Received:
    60
    Yes I have this problem too. There's a temporary workaround - kill the DJI Pilot app by going back to the homescreen, double pressing the home button, swiping away the DJI Pilot app to completely kill it, then reopen it using the icon. The latency will be fixed, at least for a few minutes. You can do this safely even when the bird is in the air.

    Probably a bug in the video buffering or decoding logic introduced in 1.2.0. I'd hope DJI would fix it, but the DJI reps here don't even seem to want to acknowledge there's a problem.
     
    PhotoGuyAaron likes this.