Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Strange pre-flight shenanigans

Discussion in 'Phantom 2 Vision + Discussion' started by 480sparky, Jul 1, 2014.

  1. 480sparky

    Joined:
    Jun 22, 2014
    Messages:
    502
    Likes Received:
    120
    Decided to take advantage of a very calm evening tonight and go fly.

    Being new, I'm trying to get into a set preflight routine, which consisted of the following:

    Power on transmitter.
    Launch DJI app on phone.
    Turn on range extender.
    Turn on P2V+.
    Calibrate compass.

    So far so good. But when the app connects with the P2V+, things get strange. I see the live video feed from the camera, which is correct. But the Battery Level, GPS Status and SD Card icons stay grayed out and never 'turn on' to their normal blue color.

    So I power off the P2V+, and power it back on. Of course, this causes the phone to display loss of connection, but it eventually reconnects as it should. But still, the three icons are grayed out. And they stay that way for at least two minutes.

    So I cycle the power off/on the P2V+ once more, with the same results. And what gets really weird is the Camera Tilt Control. It's reversed. I try to aim the camera up, and it goes down. Try to go down, it goes up.

    So........ I power everything down (in the order you should at the end of a flight), pull the battery out of the P2V+ and the transmitter, and restart my phone. Only then, after a normal 'power-up' process, does everything appear to be functioning properly and I take off.


    Having never heard of this issue........ anyone have an idea as to the cause, as well as a solution (other that try, try again)?
     
  2. platonas1

    Joined:
    May 3, 2014
    Messages:
    34
    Likes Received:
    0
    You need first to turn on range extender, then launch dji app.
    The app connects to range extender first to get telemetry from craft.

    Transmitter on
    Extender On
    PV+ On
    Dji app On

    Make sure you are connected to the extender and no to other ssid.

    If you still have issues, unistall app and install again.
     
  3. 480sparky

    Joined:
    Jun 22, 2014
    Messages:
    502
    Likes Received:
    120
    Thanks for the tips.

    I tried the order three times tonight, and had the same issues. Only restarting the phone would make everything work.

    So I'll uninstall & reinstall the app and see if that solves it.
     
  4. 480sparky

    Joined:
    Jun 22, 2014
    Messages:
    502
    Likes Received:
    120
    Well, that didn't do it.

    Went out to fly this morning, and the same situations occurred. Had to do a soft restart on the phone to clear it up.
     
  5. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    9
    Location:
    Glen Burnie, MD - USA
    Probably just some app running on your phone causing the issue. Now that you know, just always reboot your phone before you are ready to fly.
     
  6. 480sparky

    Joined:
    Jun 22, 2014
    Messages:
    502
    Likes Received:
    120
    I could do that, but I'm fearful of having the app crash while flying.
     
  7. kymedic121

    Joined:
    Jul 1, 2014
    Messages:
    230
    Likes Received:
    0
    Location:
    Arlington, Ky.
    I am unsure of the phone you are using. But in My Note 3 my app setting lets me see the apps that are running all the time. I turn off all non-essential apps that are running in the background. No app on my phone updates automatically or runs silently in the background as this causes phone glitches as not all apps play nice together. Once a week I update my apps manually all at once to get the most recent versions but I never let anything run in the background with the exception of the GPS and Verizon network required. I have noticed since doing this my phone never glitches, locks up or acts ignorant.